summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5fb6bec..7fa2f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,189 +73,179 @@ AC_COMPILE_IFELSE([
73 ],[ 73 ],[
74 AC_MSG_RESULT([no]) 74 AC_MSG_RESULT([no])
75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
76 ] 76 ]
77) 77)
78 78
79AC_LANG_PUSH([C++]) 79AC_LANG_PUSH([C++])
80AC_MSG_CHECKING([for abi::__cxa_demangle]) 80AC_MSG_CHECKING([for abi::__cxa_demangle])
81AC_COMPILE_IFELSE([ 81AC_COMPILE_IFELSE([
82 #include <typeinfo> 82 #include <typeinfo>
83 using namespace std; 83 using namespace std;
84 #include <cxxabi.h> 84 #include <cxxabi.h>
85 int main(int c,char **v) { 85 int main(int c,char **v) {
86 int dstat; 86 int dstat;
87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
88 return 0; 88 return 0;
89 } 89 }
90 ],[ 90 ],[
91 AC_MSG_RESULT([yes]) 91 AC_MSG_RESULT([yes])
92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
93 ],[ 93 ],[
94 AC_MSG_RESULT([no]) 94 AC_MSG_RESULT([no])
95 ] 95 ]
96) 96)
97AC_LANG_POP([C++]) 97AC_LANG_POP([C++])
98 98
99 99
100 100
101 101
102PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 102PKG_CHECK_MODULES([OPENSSL],[openssl],,[
103 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 103 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
104]) 104])
105 105
106WANT_KONFORKA="yes" 106WANT_KONFORKA="yes"
107AC_ARG_ENABLE([konforka], 107AC_ARG_ENABLE([konforka],
108 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 108 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
109 [ 109 [
110 test "${enableval}" = "no" && WANT_KONFORKA="no" 110 test "${enableval}" = "no" && WANT_KONFORKA="no"
111 ] 111 ]
112) 112)
113if test "${WANT_KONFORKA}" = "yes" ; then 113if test "${WANT_KONFORKA}" = "yes" ; then
114 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 114 PKG_CHECK_MODULES([KONFORKA],[konforka],[
115 AC_SUBST([KONFORKA_CFLAGS]) 115 AC_SUBST([KONFORKA_CFLAGS])
116 AC_SUBST([KONFORKA_LIBS]) 116 AC_SUBST([KONFORKA_LIBS])
117 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 117 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
118 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 118 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
119 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 119 AC_SUBST([KONFORKA_KONFORKA],[konforka])
120 ],[true]) 120 ],[true])
121fi 121fi
122 122
123WANT_DOXYGEN="yes" 123WANT_DOXYGEN="yes"
124AC_ARG_ENABLE([doxygen], 124AC_ARG_ENABLE([doxygen],
125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
126 [ 126 [
127 test "${enableval}" = "no" && WANT_DOXYGEN="no" 127 test "${enableval}" = "no" && WANT_DOXYGEN="no"
128 ] 128 ]
129) 129)
130if test "${WANT_DOXYGEN}" = "yes" ; then 130if test "${WANT_DOXYGEN}" = "yes" ; then
131 AC_WITH_DOXYGEN 131 AC_WITH_DOXYGEN
132 AC_WITH_DOT 132 AC_WITH_DOT
133else 133else
134 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 134 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
135 AM_CONDITIONAL([HAVE_DOT],[false]) 135 AM_CONDITIONAL([HAVE_DOT],[false])
136fi 136fi
137 137
138LIBCURL_CHECK_CONFIG(,,,[ 138LIBCURL_CHECK_CONFIG(,,,[
139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
140]) 140])
141 141
142AC_CHECK_HEADER([expat.h],[ 142AC_CHECK_HEADER([expat.h],[
143 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 143 AC_CHECK_LIB([expat],[XML_ParserCreate],[
144 EXPAT_LIBS=-lexpat 144 EXPAT_LIBS=-lexpat
145 EXPAT_CFLAGS= 145 EXPAT_CFLAGS=
146 AC_SUBST([EXPAT_LIBS]) 146 AC_SUBST([EXPAT_LIBS])
147 AC_SUBST([EXPAT_CFLAGS]) 147 AC_SUBST([EXPAT_CFLAGS])
148 ],[ 148 ],[
149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
150 ]) 150 ])
151],[ 151],[
152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
153]) 153])
154 154
155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[
157 TIDY_LIBS=-ltidy 157 TIDY_LIBS=-ltidy
158 TIDY_CFLAGS= 158 TIDY_CFLAGS=
159 AC_SUBST([TIDY_LIBS]) 159 AC_SUBST([TIDY_LIBS])
160 AC_SUBST([TIDY_CFLAGS]) 160 AC_SUBST([TIDY_CFLAGS])
161 ],[ 161 ],[
162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
163 ]) 163 ])
164],[ 164],[
165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \ 165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
167]) 167])
168 168
169if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
170 AC_SUBST([PCRE_CFLAGS])
171 AC_SUBST([PCRE_LIBS])
172 :
173else
174 PKG_CHECK_MODULES([PCRE],[libpcre],,[
175 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
176 ])
177fi
178
179PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
180AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
181PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
182AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
183PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
184AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 174AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
185if $have_uuid ; then 175if $have_uuid ; then
186 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 176 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
187 AC_SUBST([UUID_UUID],[uuid]) 177 AC_SUBST([UUID_UUID],[uuid])
188fi 178fi
189 179
190curl_ssl_verify_host="true" 180curl_ssl_verify_host="true"
191AC_ARG_ENABLE([ssl-verify-host], 181AC_ARG_ENABLE([ssl-verify-host],
192 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 182 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
193 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 183 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
194) 184)
195${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 185${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
196 186
197curl_ssl_verify_peer="true" 187curl_ssl_verify_peer="true"
198AC_ARG_ENABLE([ssl-verify-peer], 188AC_ARG_ENABLE([ssl-verify-peer],
199 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 189 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
200 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 190 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
201) 191)
202${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 192${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
203 193
204postels_law=true 194postels_law=true
205AC_ARG_ENABLE([postels-law], 195AC_ARG_ENABLE([postels-law],
206 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 196 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
207 [ test "${enableval}" = "no" && postels_law=false ] 197 [ test "${enableval}" = "no" && postels_law=false ]
208) 198)
209$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 199$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
210 200
211AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 201AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
212 202
213nitpick=false 203nitpick=false
214AC_ARG_ENABLE([nitpicking], 204AC_ARG_ENABLE([nitpicking],
215 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 205 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
216 [ test "$enableval" = "no" || nitpick=true ] 206 [ test "$enableval" = "no" || nitpick=true ]
217) 207)
218if $nitpick ; then 208if $nitpick ; then
219 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 209 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
220 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 210 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
221 -Wredundant-decls -ansi" 211 -Wredundant-decls -ansi"
222 # -Wlogical-op -Wmissing-noreturn 212 # -Wlogical-op -Wmissing-noreturn
223 C_NITPICK="$CPP_NITPICK" 213 C_NITPICK="$CPP_NITPICK"
224 CXX_NITPICK="$C_NITPICK" 214 CXX_NITPICK="$C_NITPICK"
225 215
226 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 216 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
227 CFLAGS="$CFLAGS $C_NITPICK" 217 CFLAGS="$CFLAGS $C_NITPICK"
228 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 218 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
229fi 219fi
230 220
231ndebug=true 221ndebug=true
232AC_ARG_ENABLE([debug], 222AC_ARG_ENABLE([debug],
233 AC_HELP_STRING([--enable-debug],[enable debugging code]), 223 AC_HELP_STRING([--enable-debug],[enable debugging code]),
234 [ test "$enableval" = "no" || ndebug=false ] 224 [ test "$enableval" = "no" || ndebug=false ]
235) 225)
236if $ndebug ; then 226if $ndebug ; then
237 CPPFLAGS_DEBUG="-DNDEBUG" 227 CPPFLAGS_DEBUG="-DNDEBUG"
238else 228else
239 CPPFLAGS_DEBUG="" 229 CPPFLAGS_DEBUG=""
240fi 230fi
241AC_SUBST([CPPFLAGS_DEBUG]) 231AC_SUBST([CPPFLAGS_DEBUG])
242 232
243xri_proxy_url="https://xri.net/" 233xri_proxy_url="https://xri.net/"
244AC_MSG_CHECKING([for XRI resolver proxy]) 234AC_MSG_CHECKING([for XRI resolver proxy])
245AC_ARG_ENABLE([xri-proxy], 235AC_ARG_ENABLE([xri-proxy],
246 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]), 236 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]),
247 [ xri_proxy_url="$withval" ] 237 [ xri_proxy_url="$withval" ]
248) 238)
249AC_MSG_RESULT([$xri_proxy_url]) 239AC_MSG_RESULT([$xri_proxy_url])
250AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) 240AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL])
251 241
252AC_CONFIG_FILES([ 242AC_CONFIG_FILES([
253 Makefile 243 Makefile
254 libopkele.pc 244 libopkele.pc
255 Doxyfile 245 Doxyfile
256 include/Makefile 246 include/Makefile
257 include/opkele/tr1-mem.h 247 include/opkele/tr1-mem.h
258 lib/Makefile 248 lib/Makefile
259 test/Makefile 249 test/Makefile
260]) 250])
261AC_OUTPUT 251AC_OUTPUT