-rw-r--r-- | configure.ac | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 51bacd5..5772ead 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -21,178 +21,191 @@ if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then | |||
21 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" | 21 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" |
22 | else | 22 | else |
23 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" | 23 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" |
24 | fi | 24 | fi |
25 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) | 25 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) |
26 | AC_SUBST([PACKAGE_SRC_VERSION]) | 26 | AC_SUBST([PACKAGE_SRC_VERSION]) |
27 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) | 27 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) |
28 | 28 | ||
29 | tr1_mem_std="false" | 29 | tr1_mem_std="false" |
30 | tr1_mem_boost="false" | 30 | tr1_mem_boost="false" |
31 | AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) | 31 | AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) |
32 | AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) | 32 | AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) |
33 | tr1_mem="" | 33 | tr1_mem="" |
34 | AC_ARG_WITH([tr1-memory], | 34 | AC_ARG_WITH([tr1-memory], |
35 | AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), | 35 | AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), |
36 | [ tr1_mem="$withval" ] | 36 | [ tr1_mem="$withval" ] |
37 | ) | 37 | ) |
38 | AC_MSG_CHECKING([for tr1/memory implementation to use]) | 38 | AC_MSG_CHECKING([for tr1/memory implementation to use]) |
39 | test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std | 39 | test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std |
40 | test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost | 40 | test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost |
41 | if test -z "$tr1_mem" ; then | 41 | if test -z "$tr1_mem" ; then |
42 | AC_MSG_RESULT([none found]) | 42 | AC_MSG_RESULT([none found]) |
43 | else | 43 | else |
44 | AC_MSG_RESULT([$tr1_mem]) | 44 | AC_MSG_RESULT([$tr1_mem]) |
45 | fi | 45 | fi |
46 | case "$tr1_mem" in | 46 | case "$tr1_mem" in |
47 | std) | 47 | std) |
48 | $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) | 48 | $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) |
49 | OPKELE_TR1_MEM_NS=std::tr1 | 49 | OPKELE_TR1_MEM_NS=std::tr1 |
50 | OPKELE_TR1_MEM_HEADER=tr1/memory | 50 | OPKELE_TR1_MEM_HEADER=tr1/memory |
51 | ;; | 51 | ;; |
52 | boost) | 52 | boost) |
53 | $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) | 53 | $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) |
54 | OPKELE_TR1_MEM_NS=boost | 54 | OPKELE_TR1_MEM_NS=boost |
55 | OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp | 55 | OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp |
56 | ;; | 56 | ;; |
57 | *) | 57 | *) |
58 | AC_MSG_ERROR([no shared_ptr<> implementation found]) | 58 | AC_MSG_ERROR([no shared_ptr<> implementation found]) |
59 | ;; | 59 | ;; |
60 | esac | 60 | esac |
61 | AC_SUBST([OPKELE_TR1_MEM_NS]) | 61 | AC_SUBST([OPKELE_TR1_MEM_NS]) |
62 | AC_SUBST([OPKELE_TR1_MEM_HEADER]) | 62 | AC_SUBST([OPKELE_TR1_MEM_HEADER]) |
63 | 63 | ||
64 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 64 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
65 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 65 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
66 | ]) | 66 | ]) |
67 | 67 | ||
68 | WANT_KONFORKA="yes" | 68 | WANT_KONFORKA="yes" |
69 | AC_ARG_ENABLE([konforka], | 69 | AC_ARG_ENABLE([konforka], |
70 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 70 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
71 | [ | 71 | [ |
72 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 72 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
73 | ] | 73 | ] |
74 | ) | 74 | ) |
75 | if test "${WANT_KONFORKA}" = "yes" ; then | 75 | if test "${WANT_KONFORKA}" = "yes" ; then |
76 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 76 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
77 | AC_SUBST([KONFORKA_CFLAGS]) | 77 | AC_SUBST([KONFORKA_CFLAGS]) |
78 | AC_SUBST([KONFORKA_LIBS]) | 78 | AC_SUBST([KONFORKA_LIBS]) |
79 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 79 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
80 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 80 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
81 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 81 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
82 | ],[true]) | 82 | ],[true]) |
83 | fi | 83 | fi |
84 | 84 | ||
85 | WANT_DOXYGEN="yes" | 85 | WANT_DOXYGEN="yes" |
86 | AC_ARG_ENABLE([doxygen], | 86 | AC_ARG_ENABLE([doxygen], |
87 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 87 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
88 | [ | 88 | [ |
89 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 89 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
90 | ] | 90 | ] |
91 | ) | 91 | ) |
92 | if test "${WANT_DOXYGEN}" = "yes" ; then | 92 | if test "${WANT_DOXYGEN}" = "yes" ; then |
93 | AC_WITH_DOXYGEN | 93 | AC_WITH_DOXYGEN |
94 | AC_WITH_DOT | 94 | AC_WITH_DOT |
95 | else | 95 | else |
96 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 96 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
97 | AM_CONDITIONAL([HAVE_DOT],[false]) | 97 | AM_CONDITIONAL([HAVE_DOT],[false]) |
98 | fi | 98 | fi |
99 | 99 | ||
100 | LIBCURL_CHECK_CONFIG(,,,[ | 100 | LIBCURL_CHECK_CONFIG(,,,[ |
101 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 101 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
102 | ]) | 102 | ]) |
103 | 103 | ||
104 | AC_CHECK_HEADER([expat.h],[ | 104 | AC_CHECK_HEADER([expat.h],[ |
105 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ | 105 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ |
106 | EXPAT_LIBS=-lexpat | 106 | EXPAT_LIBS=-lexpat |
107 | EXPAT_CFLAGS= | 107 | EXPAT_CFLAGS= |
108 | AC_SUBST([EXPAT_LIBS]) | 108 | AC_SUBST([EXPAT_LIBS]) |
109 | AC_SUBST([EXPAT_CFLAGS]) | 109 | AC_SUBST([EXPAT_CFLAGS]) |
110 | ],[ | 110 | ],[ |
111 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 111 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
112 | ]) | 112 | ]) |
113 | ],[ | 113 | ],[ |
114 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 114 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
115 | ]) | 115 | ]) |
116 | 116 | ||
117 | AC_CHECK_HEADER([tidy.h],[ | ||
118 | AC_CHECK_LIB([tidy],[tidyParseBuffer],[ | ||
119 | TIDY_LIBS=-ltidy | ||
120 | TIDY_CFLAGS= | ||
121 | AC_SUBST([TIDY_LIBS]) | ||
122 | AC_SUBST([TIDY_CFLAGS]) | ||
123 | ],[ | ||
124 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/]) | ||
125 | ]) | ||
126 | ],[ | ||
127 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/]) | ||
128 | ]) | ||
129 | |||
117 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 130 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
118 | AC_SUBST([PCRE_CFLAGS]) | 131 | AC_SUBST([PCRE_CFLAGS]) |
119 | AC_SUBST([PCRE_LIBS]) | 132 | AC_SUBST([PCRE_LIBS]) |
120 | : | 133 | : |
121 | else | 134 | else |
122 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 135 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
123 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 136 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
124 | ]) | 137 | ]) |
125 | fi | 138 | fi |
126 | 139 | ||
127 | curl_ssl_verify_host="true" | 140 | curl_ssl_verify_host="true" |
128 | AC_ARG_ENABLE([ssl-verify-host], | 141 | AC_ARG_ENABLE([ssl-verify-host], |
129 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 142 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
130 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 143 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
131 | ) | 144 | ) |
132 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 145 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
133 | 146 | ||
134 | curl_ssl_verify_peer="true" | 147 | curl_ssl_verify_peer="true" |
135 | AC_ARG_ENABLE([ssl-verify-peer], | 148 | AC_ARG_ENABLE([ssl-verify-peer], |
136 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 149 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
137 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 150 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
138 | ) | 151 | ) |
139 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 152 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
140 | 153 | ||
141 | postels_law=true | 154 | postels_law=true |
142 | AC_ARG_ENABLE([postels-law], | 155 | AC_ARG_ENABLE([postels-law], |
143 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 156 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
144 | [ test "${enableval}" = "no" && postels_law=false ] | 157 | [ test "${enableval}" = "no" && postels_law=false ] |
145 | ) | 158 | ) |
146 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 159 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
147 | 160 | ||
148 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | 161 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) |
149 | 162 | ||
150 | nitpick=false | 163 | nitpick=false |
151 | AC_ARG_ENABLE([nitpicking], | 164 | AC_ARG_ENABLE([nitpicking], |
152 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | 165 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), |
153 | [ test "$enableval" = "no" || nitpick=true ] | 166 | [ test "$enableval" = "no" || nitpick=true ] |
154 | ) | 167 | ) |
155 | if $nitpick ; then | 168 | if $nitpick ; then |
156 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | 169 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ |
157 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | 170 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ |
158 | -Wredundant-decls -ansi" | 171 | -Wredundant-decls -ansi" |
159 | # -Wlogical-op -Wmissing-noreturn | 172 | # -Wlogical-op -Wmissing-noreturn |
160 | C_NITPICK="$CPP_NITPICK" | 173 | C_NITPICK="$CPP_NITPICK" |
161 | CXX_NITPICK="$C_NITPICK" | 174 | CXX_NITPICK="$C_NITPICK" |
162 | 175 | ||
163 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" | 176 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" |
164 | CFLAGS="$CFLAGS $C_NITPICK" | 177 | CFLAGS="$CFLAGS $C_NITPICK" |
165 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" | 178 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" |
166 | fi | 179 | fi |
167 | 180 | ||
168 | ndebug=true | 181 | ndebug=true |
169 | AC_ARG_ENABLE([debug], | 182 | AC_ARG_ENABLE([debug], |
170 | AC_HELP_STRING([--enable-debug],[enable debugging code]), | 183 | AC_HELP_STRING([--enable-debug],[enable debugging code]), |
171 | [ test "$enableval" = "no" || ndebug=false ] | 184 | [ test "$enableval" = "no" || ndebug=false ] |
172 | ) | 185 | ) |
173 | if $ndebug ; then | 186 | if $ndebug ; then |
174 | CPPFLAGS_DEBUG="-DNDEBUG" | 187 | CPPFLAGS_DEBUG="-DNDEBUG" |
175 | else | 188 | else |
176 | CPPFLAGS_DEBUG="" | 189 | CPPFLAGS_DEBUG="" |
177 | fi | 190 | fi |
178 | AC_SUBST([CPPFLAGS_DEBUG]) | 191 | AC_SUBST([CPPFLAGS_DEBUG]) |
179 | 192 | ||
180 | xri_proxy_url="http://beta.xri.net/" | 193 | xri_proxy_url="http://beta.xri.net/" |
181 | AC_MSG_CHECKING([for XRI resolver proxy]) | 194 | AC_MSG_CHECKING([for XRI resolver proxy]) |
182 | AC_ARG_ENABLE([xri-proxy], | 195 | AC_ARG_ENABLE([xri-proxy], |
183 | AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is http://xr_proxy_url]), | 196 | AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is http://xr_proxy_url]), |
184 | [ xri_proxy_url="$withval" ] | 197 | [ xri_proxy_url="$withval" ] |
185 | ) | 198 | ) |
186 | AC_MSG_RESULT([$xri_proxy_url]) | 199 | AC_MSG_RESULT([$xri_proxy_url]) |
187 | AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) | 200 | AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) |
188 | 201 | ||
189 | AC_CONFIG_FILES([ | 202 | AC_CONFIG_FILES([ |
190 | Makefile | 203 | Makefile |
191 | libopkele.pc | 204 | libopkele.pc |
192 | Doxyfile | 205 | Doxyfile |
193 | include/Makefile | 206 | include/Makefile |
194 | include/opkele/tr1-mem.h | 207 | include/opkele/tr1-mem.h |
195 | lib/Makefile | 208 | lib/Makefile |
196 | test/Makefile | 209 | test/Makefile |
197 | ]) | 210 | ]) |
198 | AC_OUTPUT | 211 | AC_OUTPUT |