summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
Side-by-side diff
Diffstat (limited to 'test/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--test/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 61e3787..8fedf48 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,2 +1,2 @@
-noinst_PROGRAMS = test idiscover RP.cgi
+noinst_PROGRAMS = test idiscover RP.cgi OP.cgi
@@ -10,4 +10,4 @@ test_LDADD = ${top_builddir}/lib/libopkele.la
EXTRA_DIST= \
- sqlite.h \
- RP-db.sql
+ sqlite.h kingate_openid_message.h \
+ RP-db.sql OP-db.sql
@@ -33,4 +33,16 @@ RP-db.cc: RP-db.sql
+OP_cgi_SOURCES = OP.cc
+nodist_OP_cgi_SOURCES = OP-db.cc
+OP_cgi_LDADD = ${RP_cgi_LDADD}
+OP_cgi_CFLAGS = ${RP_cgi_CFLAGS}
+
+OP-db.cc: OP-db.sql
+ ( \
+ echo 'const char * __OP_db_bootstrap = ' && \
+ sed -e 's/^/"/' -e 's/$$/"/' $< && \
+ echo ';' \
+ ) >$@
+
clean-local:
- rm -f RP-db.cc
+ rm -f RP-db.cc OP-db.cc