summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
Unidiff
Diffstat (limited to 'test/Makefile.am') (more/less context) (show whitespace changes)
-rw-r--r--test/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 61e3787..8fedf48 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,2 +1,2 @@
1noinst_PROGRAMS = test idiscover RP.cgi 1noinst_PROGRAMS = test idiscover RP.cgi OP.cgi
2 2
@@ -10,4 +10,4 @@ test_LDADD = ${top_builddir}/lib/libopkele.la
10EXTRA_DIST= \ 10EXTRA_DIST= \
11 sqlite.h \ 11 sqlite.h kingate_openid_message.h \
12 RP-db.sql 12 RP-db.sql OP-db.sql
13 13
@@ -33,4 +33,16 @@ RP-db.cc: RP-db.sql
33 33
34OP_cgi_SOURCES = OP.cc
35nodist_OP_cgi_SOURCES = OP-db.cc
36OP_cgi_LDADD = ${RP_cgi_LDADD}
37OP_cgi_CFLAGS = ${RP_cgi_CFLAGS}
38
39OP-db.cc: OP-db.sql
40 ( \
41 echo 'const char * __OP_db_bootstrap = ' && \
42 sed -e 's/^/"/' -e 's/$$/"/' $< && \
43 echo ';' \
44 ) >$@
45
34clean-local: 46clean-local:
35 rm -f RP-db.cc 47 rm -f RP-db.cc OP-db.cc
36 48