summaryrefslogtreecommitdiffabout
path: root/Makefile.am
authorMichael Krelin <hacker@klever.net>2005-02-02 22:30:27 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-02 22:30:27 (UTC)
commit870963df2dac72e433fd7f94cd1cccc8cd6ea2d0 (patch) (unidiff)
treeedb6a3f9070ca67c9396ce548f28f82107afc119 /Makefile.am
parentb9ddf0a5135cf5b3371f38b41385fa8fc03da146 (diff)
downloadsitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.zip
sitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.tar.gz
sitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.tar.bz2
1. changed version to -svn
2. added a really simple page example 3. removed 'border=' attribute from iframe 4. added notice about svn version 5. added 'site-C-ing:' prefix to the title
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 529f5ae..105b377 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,35 +1,36 @@
1EXTRA_DIST = \ 1EXTRA_DIST = \
2 $(addprefix htdocs/,.htaccess favicon.ico index.chtml sources.chtml style.css view.chtml) \ 2 $(addprefix htdocs/,.htaccess favicon.ico index.chtml simple.chtml sources.chtml style.css view.chtml) \
3 $(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \ 3 $(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \
4 $(addprefix htdocs/examples/,calendar.chtml) \
4 $(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \ 5 $(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \
5 $(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \ 6 $(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
6 $(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \ 7 $(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
7 $(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \ 8 $(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \
8 autogen.sh \ 9 autogen.sh \
9 NEWS NEWS.xml NEWS.xsl 10 NEWS NEWS.xml NEWS.xsl
10 11
11DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck 12DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck
12 13
13all-local: NEWS sitecode restart restart-apache 14all-local: NEWS sitecode restart restart-apache
14distclean-local: 15distclean-local:
15 rm -rf config.sitecing \ 16 rm -rf config.sitecing \
16 logs fastcgi-bin run cache 17 logs fastcgi-bin run cache
17 18
18NEWS: NEWS.xsl NEWS.xml 19NEWS: NEWS.xsl NEWS.xml
19 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml 20 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
20 21
21sitecode: conf/sitecing.conf include/acconfig.h 22sitecode: conf/sitecing.conf include/acconfig.h
22 ${SHELL} bin/build 23 ${SHELL} bin/build
23restart: conf/sitecing.conf conf/dudki.conf 24restart: conf/sitecing.conf conf/dudki.conf
24if !DISTCHECKING 25if !DISTCHECKING
25if HAVE_DUDKI 26if HAVE_DUDKI
26 sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r" 27 sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r"
27else 28else
28 kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run 29 kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run
29endif 30endif
30endif !DISTCHECKING 31endif !DISTCHECKING
31 32
32restart-apache: conf/httpd.conf 33restart-apache: conf/httpd.conf
33if !DISTCHECKING 34if !DISTCHECKING
34 @APACHE_RESTART_CMD@ 35 @APACHE_RESTART_CMD@
35endif !DISTCHECKING 36endif !DISTCHECKING