summaryrefslogtreecommitdiffabout
path: root/Makefile.am
authorMichael Krelin <hacker@klever.net>2005-02-02 22:30:27 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-02 22:30:27 (UTC)
commit870963df2dac72e433fd7f94cd1cccc8cd6ea2d0 (patch) (side-by-side diff)
treeedb6a3f9070ca67c9396ce548f28f82107afc119 /Makefile.am
parentb9ddf0a5135cf5b3371f38b41385fa8fc03da146 (diff)
downloadsitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.zip
sitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.tar.gz
sitecing-870963df2dac72e433fd7f94cd1cccc8cd6ea2d0.tar.bz2
1. changed version to -svn
2. added a really simple page example 3. removed 'border=' attribute from iframe 4. added notice about svn version 5. added 'site-C-ing:' prefix to the title
Diffstat (limited to 'Makefile.am') (more/less context) (show whitespace changes)
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 529f5ae..105b377 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,35 +1,36 @@
EXTRA_DIST = \
- $(addprefix htdocs/,.htaccess favicon.ico index.chtml sources.chtml style.css view.chtml) \
+ $(addprefix htdocs/,.htaccess favicon.ico index.chtml simple.chtml sources.chtml style.css view.chtml) \
$(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \
+ $(addprefix htdocs/examples/,calendar.chtml) \
$(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \
$(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
$(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
$(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \
autogen.sh \
NEWS NEWS.xml NEWS.xsl
DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck
all-local: NEWS sitecode restart restart-apache
distclean-local:
rm -rf config.sitecing \
logs fastcgi-bin run cache
NEWS: NEWS.xsl NEWS.xml
${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
sitecode: conf/sitecing.conf include/acconfig.h
${SHELL} bin/build
restart: conf/sitecing.conf conf/dudki.conf
if !DISTCHECKING
if HAVE_DUDKI
sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r"
else
kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run
endif
endif !DISTCHECKING
restart-apache: conf/httpd.conf
if !DISTCHECKING
@APACHE_RESTART_CMD@
endif !DISTCHECKING