summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index acd34b9..0da7658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,37 +1,55 @@
1AC_INIT([sitecing], [0.0], [sitecing-bugs@klever.net]) 1AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h]) 2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_AWK 7AC_PROG_AWK
8AC_PROG_CXX 8AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10AM_PROG_LEX 10AM_PROG_LEX
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12 12
13AC_HEADER_STDC 13AC_HEADER_STDC
14AC_CHECK_HEADERS([stdlib.h unistd.h]) 14AC_CHECK_HEADERS([stdlib.h unistd.h])
15 15
16AC_C_CONST 16AC_C_CONST
17 17
18AC_FUNC_MALLOC 18AC_FUNC_MALLOC
19AC_FUNC_REALLOC 19AC_FUNC_REALLOC
20 20
21AC_WITH_PKGCONFIG 21AC_WITH_PKGCONFIG
22 22
23PKG_CHECK_MODULES([KINGATE],[kingate-fcgi],,[ 23PKG_CHECK_MODULES([KINGATE],[kingate],,[
24 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/]) 24 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
25]) 25])
26HAVE_FCGI=false
27HAVE_PLAINCGI=false
28PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi],[
29 HAVE_FCGI=true
30],[
31 AC_MSG_NOTICE([no fastcgi support in kingate library])
32])
33PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi],[
34 HAVE_PLAINCGI=true
35],[
36 AC_MSG_NOTICE([no plaincgi support in kingate library])
37])
38if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
39 AC_MSG_ERROR([not a single CGI interface supported in kingate])
40fi
41AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
42AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
43
26PKG_CHECK_MODULES([DOTCONF],[dotconf],,[ 44PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
27 AC_MSG_ERROR([no dotconf library found]) 45 AC_MSG_ERROR([no dotconf library found])
28]) 46])
29 47
30AC_WITH_PCRE([ 48AC_WITH_PCRE([
31 AC_WITH_PCREPP(,[ 49 AC_WITH_PCREPP(,[
32 AC_MSG_ERROR([no pcre++ library found]) 50 AC_MSG_ERROR([no pcre++ library found])
33 ]) 51 ])
34],[ 52],[
35 AC_MSG_ERROR([no pcre library found]) 53 AC_MSG_ERROR([no pcre library found])
36]) 54])
37 55