summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fde326b..bb1557a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,93 +1,93 @@
1AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net]) 1AC_INIT([sitecing], [0.0.2], [sitecing-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h]) 2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_AWK 7AC_PROG_AWK
8AC_PROG_CXX 8AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10AM_PROG_LEX 10AM_PROG_LEX
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12 12
13AC_HEADER_STDC 13AC_HEADER_STDC
14AC_CHECK_HEADERS([stdlib.h unistd.h]) 14AC_CHECK_HEADERS([stdlib.h unistd.h])
15 15
16AC_C_CONST 16AC_C_CONST
17 17
18AC_FUNC_MALLOC 18AC_FUNC_MALLOC
19AC_FUNC_REALLOC 19AC_FUNC_REALLOC
20 20
21AC_WITH_PKGCONFIG 21AC_WITH_PKGCONFIG
22 22
23PKG_CHECK_MODULES([KONFORKA],[konforka >= 0.0.1],,[ 23PKG_CHECK_MODULES([KONFORKA],[konforka >= 0.0.1],,[
24 AC_MSG_ERROR([no proper version of konforka library found, get it at http://kin.klever.net/konforka/]) 24 AC_MSG_ERROR([no proper version of konforka library found, get it at http://kin.klever.net/konforka/])
25]) 25])
26 26
27PKG_CHECK_MODULES([KINGATE],[kingate >= 0.0.1],,[ 27PKG_CHECK_MODULES([KINGATE],[kingate >= 0.0.1],,[
28 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/]) 28 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
29]) 29])
30HAVE_FCGI=false 30HAVE_FCGI=false
31HAVE_PLAINCGI=false 31HAVE_PLAINCGI=false
32PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi >= 0.0.1],[ 32PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi >= 0.0.1],[
33 HAVE_FCGI=true 33 HAVE_FCGI=true
34],[ 34],[
35 AC_MSG_NOTICE([no fastcgi support in kingate library]) 35 AC_MSG_NOTICE([no fastcgi support in kingate library])
36]) 36])
37PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi >= 0.0.1],[ 37PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi >= 0.0.1],[
38 HAVE_PLAINCGI=true 38 HAVE_PLAINCGI=true
39],[ 39],[
40 AC_MSG_NOTICE([no plaincgi support in kingate library]) 40 AC_MSG_NOTICE([no plaincgi support in kingate library])
41]) 41])
42if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then 42if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
43 AC_MSG_ERROR([not a single CGI interface supported in kingate]) 43 AC_MSG_ERROR([not a single CGI interface supported in kingate])
44fi 44fi
45AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}]) 45AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
46AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}]) 46AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
47 47
48PKG_CHECK_MODULES([DOTCONF],[dotconf],,[ 48PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
49 AC_MSG_ERROR([no dotconf library found]) 49 AC_MSG_ERROR([no dotconf library found])
50]) 50])
51 51
52AC_WITH_PCRE([ 52AC_WITH_PCRE([
53 AC_WITH_PCREPP(,[ 53 AC_WITH_PCREPP(,[
54 AC_MSG_ERROR([no pcre++ library found]) 54 AC_MSG_ERROR([no pcre++ library found])
55 ]) 55 ])
56],[ 56],[
57 AC_MSG_ERROR([no pcre library found]) 57 AC_MSG_ERROR([no pcre library found])
58]) 58])
59 59
60AC_CHECK_FUNC([dlopen],,[ 60AC_CHECK_FUNC([dlopen],,[
61 AC_CHECK_LIB([dl],[dlopen],,[ 61 AC_CHECK_LIB([dl],[dlopen],,[
62 AC_MSG_ERROR([no dlopen library found]) 62 AC_MSG_ERROR([no dlopen library found])
63 ]) 63 ])
64]) 64])
65 65
66AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 66AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
67 67
68WANT_DOXYGEN="yes" 68WANT_DOXYGEN="yes"
69AC_ARG_ENABLE([doxygen], 69AC_ARG_ENABLE([doxygen],
70 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 70 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
71 [ 71 [
72 test "${enableval}" = "no" && WANT_DOXYGEN="no" 72 test "${enableval}" = "no" && WANT_DOXYGEN="no"
73 ] 73 ]
74) 74)
75if test "${WANT_DOXYGEN}" = "yes" ; then 75if test "${WANT_DOXYGEN}" = "yes" ; then
76 AC_WITH_DOXYGEN 76 AC_WITH_DOXYGEN
77 AC_WITH_DOT 77 AC_WITH_DOT
78else 78else
79 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 79 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
80 AM_CONDITIONAL([HAVE_DOT],[false]) 80 AM_CONDITIONAL([HAVE_DOT],[false])
81fi 81fi
82 82
83AC_CONFIG_FILES([ 83AC_CONFIG_FILES([
84 Makefile 84 Makefile
85 Doxyfile 85 Doxyfile
86 sitecing.pc 86 sitecing.pc
87 include/Makefile 87 include/Makefile
88 lib/Makefile 88 lib/Makefile
89 share/Makefile 89 share/Makefile
90 src/Makefile 90 src/Makefile
91 components/Makefile 91 components/Makefile
92]) 92])
93AC_OUTPUT 93AC_OUTPUT