summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy-svn/schemaspy-svn-304.ebuild
Unidiff
Diffstat (limited to 'dev-db/schemaspy-svn/schemaspy-svn-304.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy-svn/schemaspy-svn-304.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/schemaspy-svn/schemaspy-svn-304.ebuild b/dev-db/schemaspy-svn/schemaspy-svn-304.ebuild
new file mode 100644
index 0000000..80ba3a9
--- a/dev/null
+++ b/dev-db/schemaspy-svn/schemaspy-svn-304.ebuild
@@ -0,0 +1,53 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit subversion eutils java-pkg-2 java-ant-2
6
7OPN="${PN%-svn}"
8
9ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/${OPN}/trunk"
10ESVN_PROJECT="schemaspy"
11ESVN_OPTIONS="-r${PV}"
12
13DESCRIPTION="Graphical database schema metadata browser"
14HOMEPAGE="http://schemaspy.sourceforge.net/"
15LICENSE="LGPL-2.1"
16SLOT="0"
17KEYWORDS="~amd64 ~x86"
18IUSE="postgres firebird oracle mysql"
19
20DEPEND="
21 >=virtual/jdk-1.5
22 dev-java/ant-core
23 app-arch/unzip
24"
25RDEPEND="
26 >=virtual/jre-1.5
27 postgres? ( dev-java/jdbc3-postgresql )
28 firebird? ( dev-java/jdbc3-firebird )
29 oracle? ( dev-java/jdbc3-oracle )
30 mysql? ( dev-java/jdbc-mysql )
31 !dev-db/schemaspy
32"
33
34src_unpack() {
35 subversion_src_unpack
36 use postgres && java-pkg_jar-from jdbc3-postgresql-1
37 use firebird && java-pkg_jar-from jdbc3-firebird
38 # XXX: I don't know if it's the right name for oracle package
39 use oracle && java-pkg_jar-from jdbc3-oracle
40 use mysql && java-pkg_jar-from jdbc-mysql
41}
42
43src_compile() {
44 eant || die "Failed compile"
45}
46
47src_install() {
48 java-pkg_dojar dist/schemaSpy.jar
49 java-pkg_dolauncher ${OPN}
50 insinto /etc/java-config-2/launcher.d/
51 newins ${FILESDIR}/${OPN}.launcherd ${PN}
52 dodoc dist/index.html dist/releaseNotes.html
53}