Diffstat (limited to 'net-im/jabberd/jabberd-2.1.11-r2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r-- | net-im/jabberd/jabberd-2.1.11-r2.ebuild | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/net-im/jabberd/jabberd-2.1.11-r2.ebuild b/net-im/jabberd/jabberd-2.1.11-r2.ebuild index 9445d07..b1bf9f4 100644 --- a/net-im/jabberd/jabberd-2.1.11-r2.ebuild +++ b/net-im/jabberd/jabberd-2.1.11-r2.ebuild | |||
@@ -1,69 +1,69 @@ | |||
1 | # Copyright 1999-2007 Gentoo Foundation | 1 | # Copyright 1999-2007 Gentoo Foundation |
2 | # Distributed under the terms of the GNU General Public License v2 | 2 | # Distributed under the terms of the GNU General Public License v2 |
3 | # $Header: $ | 3 | # $Header: $ |
4 | 4 | ||
5 | WANT_AUTOCONF="lastest" | 5 | WANT_AUTOCONF="latest" |
6 | WANT_AUTOMAKE="none" | 6 | WANT_AUTOMAKE="none" |
7 | inherit pam eutils postgresql autotools | 7 | inherit pam eutils postgresql autotools |
8 | 8 | ||
9 | DESCRIPTION="Open Source Jabber Server" | 9 | DESCRIPTION="Open Source Jabber Server" |
10 | HOMEPAGE="http://jabberd2.xiaoka.com/" | 10 | HOMEPAGE="http://jabberd2.xiaoka.com/" |
11 | SRC_URI="http://ftp.xiaoka.com/${PN}2/releases/${P}.tar.bz2" | 11 | SRC_URI="http://ftp.xiaoka.com/${PN}2/releases/${P}.tar.bz2" |
12 | 12 | ||
13 | SLOT="0" | 13 | SLOT="0" |
14 | LICENSE="GPL-2" | 14 | LICENSE="GPL-2" |
15 | KEYWORDS="~amd64 ~ppc ~sparc ~x86" | 15 | KEYWORDS="~amd64 ~ppc ~sparc ~x86" |
16 | IUSE="debug memdebug ldap mysql pam pipe postgres sqlite ssl berkdb anon fs" | 16 | IUSE="debug memdebug ldap mysql pam pipe postgres sqlite ssl berkdb anon fs" |
17 | 17 | ||
18 | RDEPEND=">=net-im/jabber-base-0.01 | 18 | RDEPEND=">=net-im/jabber-base-0.01 |
19 | ssl? ( >=dev-libs/openssl-0.9.6b ) | 19 | ssl? ( >=dev-libs/openssl-0.9.6b ) |
20 | idn? ( net-dns/libidn ) | 20 | idn? ( net-dns/libidn ) |
21 | ldap? ( net-nds/openldap ) | 21 | ldap? ( net-nds/openldap ) |
22 | berkdb? ( >=sys-libs/db-4.1.25 ) | 22 | berkdb? ( >=sys-libs/db-4.1.25 ) |
23 | mysql? ( virtual/mysql ) | 23 | mysql? ( virtual/mysql ) |
24 | postgres? ( virtual/postgresql-libs ) | 24 | postgres? ( virtual/postgresql-libs ) |
25 | sqlite? ( =dev-db/sqlite-3* ) | 25 | sqlite? ( =dev-db/sqlite-3* ) |
26 | dev-libs/expat | 26 | dev-libs/expat |
27 | dev-libs/cyrus-sasl" | 27 | dev-libs/cyrus-sasl" |
28 | DEPEND="${RDEPEND}" | 28 | DEPEND="${RDEPEND}" |
29 | 29 | ||
30 | src_unpack() { | 30 | src_unpack() { |
31 | unpack $A | 31 | unpack $A |
32 | cd "$S" | 32 | cd "$S" |
33 | epatch "${FILESDIR}/${PF}.patch" | 33 | epatch "${FILESDIR}/${PF}.patch" |
34 | eautoreconf | 34 | eautoreconf |
35 | } | 35 | } |
36 | 36 | ||
37 | src_compile() { | 37 | src_compile() { |
38 | 38 | ||
39 | if use memdebug && ! use debug ; then | 39 | if use memdebug && ! use debug ; then |
40 | ewarn '"memdebug" requires "debug"' | 40 | ewarn '"memdebug" requires "debug"' |
41 | fi | 41 | fi |
42 | 42 | ||
43 | local pgconfigbin | 43 | local pgconfigbin |
44 | use postgres && pgconfigbin="$(postgresql_get_pgconfig)" | 44 | use postgres && pgconfigbin="$(postgresql_get_pgconfig)" |
45 | # gsasl backend is disabled due to the lack of proper gsasl in the tree | 45 | # gsasl backend is disabled due to the lack of proper gsasl in the tree |
46 | # TODO: rework postgres part in configure.ac | 46 | # TODO: rework postgres part in configure.ac |
47 | # TODO: conditionally add extra include path for db_includedir from | 47 | # TODO: conditionally add extra include path for db_includedir from |
48 | # db-use.eclass | 48 | # db-use.eclass |
49 | econf \ | 49 | econf \ |
50 | --localstatedir=/var \ | 50 | --localstatedir=/var \ |
51 | --sysconfdir=/etc/jabber \ | 51 | --sysconfdir=/etc/jabber \ |
52 | $(use_enable debug) \ | 52 | $(use_enable debug) \ |
53 | $(use_enable memdebug nad-debug) $(use_enable memdebug pool-debug) \ | 53 | $(use_enable memdebug nad-debug) $(use_enable memdebug pool-debug) \ |
54 | --enable-sasl=cyrus \ | 54 | --enable-sasl=cyrus \ |
55 | $(use_enable ssl) \ | 55 | $(use_enable ssl) \ |
56 | $(use_enable mysql) \ | 56 | $(use_enable mysql) \ |
57 | $(use_enable postgres pgsql "$pgconfigbin") \ | 57 | $(use_enable postgres pgsql "$pgconfigbin") \ |
58 | $(use_enable sqlite) \ | 58 | $(use_enable sqlite) \ |
59 | $(use_enable berkdb db) \ | 59 | $(use_enable berkdb db) \ |
60 | $(use_enable ldap) \ | 60 | $(use_enable ldap) \ |
61 | $(use_enable pam) \ | 61 | $(use_enable pam) \ |
62 | $(use_enable pipe) \ | 62 | $(use_enable pipe) \ |
63 | $(use_enable anon) \ | 63 | $(use_enable anon) \ |
64 | $(use_enable fs) \ | 64 | $(use_enable fs) \ |
65 | || die "econf failed" | 65 | || die "econf failed" |
66 | emake || die "make failed" | 66 | emake || die "make failed" |
67 | 67 | ||
68 | } | 68 | } |
69 | 69 | ||