summaryrefslogtreecommitdiff
path: root/core/pim/datebook/datebookweek.h
Unidiff
Diffstat (limited to 'core/pim/datebook/datebookweek.h') (more/less context) (ignore whitespace changes)
-rw-r--r--core/pim/datebook/datebookweek.h16
1 files changed, 16 insertions, 0 deletions
diff --git a/core/pim/datebook/datebookweek.h b/core/pim/datebook/datebookweek.h
index 6e675f1..acbc2c7 100644
--- a/core/pim/datebook/datebookweek.h
+++ b/core/pim/datebook/datebookweek.h
@@ -133,6 +133,22 @@ private slots:
133 133
134private: 134private:
135 void getEvents(); 135 void getEvents();
136
137 /**
138 * Wow that's a hell lot of code duplication
139 * in datebook. I vote for a common base class
140 * but never the less. This add a note
141 * that the Event is an all day event
142 *
143 */
144 void generateAllDayTooltext( QString& text );
145
146 /**
147 * This will add the times to the text
148 * It will be shown in the Tooltip bubble
149 */
150 void generateNormalTooltext( QString& text,
151 const EffectiveEvent &ev);
136 int year; 152 int year;
137 int _week; 153 int _week;
138 int dow; 154 int dow;