summaryrefslogtreecommitdiff
path: root/noncore/multimedia/opieplayer2/audiowidget.cpp
AgeCommit message (Expand)AuthorFilesLines
2002-12-09- back to a vector :Psimon1-3/+4
2002-12-09- less indexing in the mouse event handlersimon1-11/+14
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon1-3/+3
2002-12-09- merged duplicated setToggleButton methodsimon1-8/+0
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon1-19/+0
2002-12-09- pixBg is now backgroundPixmap and shared in the base classsimon1-6/+6
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon1-11/+2
2002-12-09- migrating from a button vector to a button mapsimon1-5/+5
2002-12-09- merged the two button setup loopssimon1-10/+8
2002-12-09- merged the separate mask and pixmap arrays into the Button structuresimon1-15/+10
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon1-2/+2
2002-12-09- re-organizing a bit the button storage. more to come.simon1-21/+21
2002-12-09- isToggle is now an enum ButtonType { NormalButton, ToggleButton };simon1-6/+4
2002-12-09- another hardcoded number removed :)simon1-1/+1
2002-12-09- buttonPixUp/Down are now vectors, toosimon1-15/+7
2002-12-09- use a vector to store the maskssimon1-10/+9
2002-12-09- one global variable lesssimon1-4/+3
2002-12-09- Key_Space triggers togglePaused()simon1-9/+1
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon1-8/+0
2002-12-08- some preparations for further code cleanups for paintButton callssimon1-6/+6
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon1-6/+1
2002-12-08- merged xoff/yoff into a QPointe member variable, shared in the base classsimon1-7/+7
2002-12-08- share the imgButtonMask member variable in the base classsimon1-6/+6
2002-12-08- share the buttons data in a buttons member variable in the base classsimon1-25/+25
2002-12-08- unused variables removedsimon1-22/+0
2002-12-08- made audioButtons a member variable here, toosimon1-4/+24
2002-12-08- merged duplicated MediaButton definition into common MediaWidget::Buttonsimon1-2/+2
2002-12-08- minor cleanupsimon1-5/+8
2002-12-05damn.. wrong thing hehellornkcor1-1/+1
2002-12-05trying to keep up with tronical.. just removed unused parameters.llornkcor1-1/+1
2002-12-02- yay, last singleton gone. global playList variable is no more :)simon1-2/+2
2002-12-02- centralized closeEvent implementationsimon1-5/+0
2002-12-02- centralized the button command handling into MediaWidget (as it issimon1-25/+5
2002-12-02- the audiowidget and the videowidget don't rely on the mediaplayerstatesimon1-38/+37
2002-12-02- less code duplicationsimon1-2/+0
2002-12-02- inherit from MediaWidgetsimon1-3/+2
2002-12-02- oops, realized it's not MediaType but rather DisplayTypesimon1-7/+7
2002-12-02- adapted to the new MediaPlayerState::MediaTypesimon1-8/+7
2002-12-02- added a missing constsimon1-30/+23
2002-12-02- use currentTab() instead of whichList()simon1-2/+2
2002-12-02- paused() -> isPaused() and the like for all accessor functions in thesimon1-5/+5
2002-12-02- made isPaused, isPlaying and isStopped private member variablessimon1-2/+2
2002-11-10*** empty log message ***llornkcor1-2/+7
2002-11-10use users default colors for tickerllornkcor1-41/+6
2002-11-10better seek slider code for videowidget tooharlekin1-4/+5
2002-11-10besser seekable handlingharlekin1-16/+17
2002-10-01mediadetect no longer needed, also beginning of id3 etc tag info support alon...harlekin1-21/+4
2002-09-24adapted to the new apiharlekin1-1/+1
2002-09-19tweaked gui placement better for landscapellornkcor1-3/+3
2002-09-05ignore next and prev buttons when playing from filelist, for nowllornkcor1-2/+5