summaryrefslogtreecommitdiff
path: root/noncore/multimedia/opieplayer2/mediawidget.cpp
AgeCommit message (Collapse)AuthorFilesLines
2004-09-23-Remove bogus whitespaceszecke1-18/+11
-Remove stl dependency -Make switching from fullscreen video to audio work -Remove debug output
2004-03-02fix includeschicken1-1/+0
2004-03-02applied the patch generated by the optimize_connect script fromalwin1-6/+6
TT.
2003-11-17merge branch with headchicken1-2/+0
2003-08-09Merge from BRANCH_1_0kergoth1-0/+2
2003-07-31- need an assert.h inclusion heresimon1-0/+2
2002-12-14- reduce memory usage a little bit by not storing the images after theysimon1-0/+1
got converted to pixmaps
2002-12-14- oops, forgot this onesimon1-1/+1
2002-12-14- kill the flickery when painting. backgroundmode is now alwayssimon1-14/+8
NoBackground and we do full double-buffering in the paintEvent
2002-12-11- copyright notice fixletsimon1-8/+7
2002-12-11- collect arguments passed to the skin loading into a structuresimon1-3/+3
2002-12-11- less code duplication. code from resizeEvent is now shared as well assimon1-0/+33
the image composing method and the pixmap mask helper
2002-12-11- moved default skin name reading over to skin classsimon1-8/+1
2002-12-11- minor cleanupsimon1-6/+4
2002-12-11- slight simplification in the APIsimon1-3/+3
2002-12-11- button mask composing moved to Skin classsimon1-22/+2
2002-12-11- moved the remaining pieces of image/pixmap loading to the Skin classsimon1-13/+9
2002-12-11- more image loading functionality moved to the Skin classsimon1-2/+2
2002-12-11- starting to factor out the actual skin image loading into a separatesimon1-1/+4
class
2002-12-11- less qimage<>qpixmap conversionssimon1-5/+6
2002-12-11- make more use of the Resource::* api for loading the datasimon1-2/+2
2002-12-11- centralize more of the skin loading code, so it can be factored out latersimon1-0/+23
more easily
2002-12-09- hah, the improved design pays off :) switching skins at run-time nowsimon1-0/+3
only reloads the pixmaps and no more requires a restart or re-creation of the audio/video widgets and the xine control (which involved slow xine initialization)
2002-12-09- the skin loading code is now centralized. no more duplicated code :)simon1-0/+43
2002-12-09- reworked the mouse event handling to be much simplersimon1-45/+39
- fixed missing return in Play case in handleCommand, which accidentially broke pausing - accept the key events we receive in the audioWidget - commented out suspicious connect to pauseCheck in mediaplayer, which broke pausing via space bar
2002-12-09- another small cleanup in the mouse handlingsimon1-0/+10
2002-12-09- yay, mouseMoveEvent is no more duplicated code :)simon1-0/+44
2002-12-09- removing duplicated code in VideoWidgetsimon1-0/+5
2002-12-09- transition to MediaWidget::Command completedsimon1-0/+9
2002-12-09- back to a vector :Psimon1-1/+2
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon1-9/+3
of an index
2002-12-09- merged duplicated setToggleButton methodsimon1-1/+11
- minor fixlet for paintAllButtons
2002-12-09- minor cleanup in paintEventsimon1-5/+9
2002-12-09- minor cleanupsimon1-4/+7
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon1-0/+28
base class
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon1-1/+9
base class now :)
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon1-1/+7
2002-12-08- oops, forgot to commit this onesimon1-0/+6
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon1-0/+8
button into a shared isOverButton method
2002-12-08- I'm re-using code from the others, so add their copyright :)simon1-0/+3
2002-12-02- yay, last singleton gone. global playList variable is no more :)simon1-6/+4
2002-12-02- centralized closeEvent implementationsimon1-0/+5
2002-12-02- centralized the button command handling into MediaWidget (as it issimon1-1/+18
duplicated between AudioWidget and VideoWidget -- the latter still to come though)
2002-12-02- the audiowidget and the videowidget don't rely on the mediaplayerstatesimon1-5/+5
singleton anymore
2002-12-02- less code duplicationsimon1-0/+4
2002-12-02- new base class for AudioWidget and VideoWidgetsimon1-0/+37