summaryrefslogtreecommitdiff
path: root/noncore/multimedia/opieplayer2
AgeCommit message (Expand)AuthorFilesLines
2002-12-09- migrating from a button vector to a button mapsimon3-17/+18
2002-12-09- merged the two button setup loopssimon1-10/+8
2002-12-09- merged the separate mask and pixmap arrays into the Button structuresimon2-19/+15
2002-12-09- moving some variables to the base classsimon2-6/+7
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon3-7/+7
2002-12-09- re-organizing a bit the button storage. more to come.simon2-21/+28
2002-12-09- isToggle is now an enum ButtonType { NormalButton, ToggleButton };simon3-13/+10
2002-12-09- another hardcoded number removed :)simon1-1/+1
2002-12-09- buttonPixUp/Down are now vectors, toosimon2-18/+10
2002-12-09- use a vector to store the maskssimon2-11/+12
2002-12-09- one global variable lesssimon2-4/+4
2002-12-09 switch (mouse) {simon1-4/+4
2002-12-09- replaced currentFileListView method with a variablesimon2-17/+12
2002-12-09- use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE andsimon3-8/+4
2002-12-09- Key_Space triggers togglePaused()simon1-9/+1
2002-12-08- synchronizing the button indices a bit more with the audiowidgetsimon2-6/+6
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon6-17/+9
2002-12-08- oops, forgot to commit this onesimon1-0/+6
2002-12-08- some preparations for further code cleanups for paintButton callssimon5-14/+17
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon4-12/+12
2002-12-08- merged xoff/yoff into a QPointe member variable, shared in the base classsimon5-17/+17
2002-12-08- made XineControl independent from VideoWidgetsimon3-12/+11
2002-12-08- share the imgButtonMask member variable in the base classsimon5-14/+14
2002-12-08- no need to include audio and videowidget.h heresimon1-2/+0
2002-12-08- share the buttons data in a buttons member variable in the base classsimon5-50/+48
2002-12-08- #include cleanupsimon1-7/+0
2002-12-08- I'm re-using code from the others, so add their copyright :)simon2-0/+6
2002-12-08- unused variables removedsimon3-39/+1
2002-12-08- made audioButtons a member variable here, toosimon2-4/+26
2002-12-08- made videoButtons a member variable instead of a global onesimon3-5/+29
2002-12-08- merged duplicated MediaButton definition into common MediaWidget::Buttonsimon3-9/+13
2002-12-08- minor cleanupsimon2-10/+15
2002-12-08- properly shut down xine in the destructor. fixes crashes when switchingsimon1-0/+7
2002-12-08- when the file list view is visible only enable the play button if theresimon3-0/+40
2002-12-05- adapted to xine CVS HEADsimon2-32/+37
2002-12-05- fixed a minor memory leaksimon1-9/+8
2002-12-05- turned if ( foo ) delete foo; into straight delete foo; as the if issimon2-11/+8
2002-12-05damn.. wrong thing hehellornkcor1-1/+1
2002-12-05trying to keep up with tronical.. just removed unused parameters.llornkcor2-2/+2
2002-12-04- scanForAudio and scanForVideo is scanFiles in the file list view, sosimon2-13/+2
2002-12-04- scannedFiles is no more publicsimon2-20/+4
2002-12-04- the doclnkset is now fully encapsulated in PlayListFileView, no needsimon1-1/+0
2002-12-04- move more view population logic into PlayListFileViewsimon4-28/+20
2002-12-04- merged popuplateAudioView and popuplateVideoView into onesimon4-74/+40
2002-12-04- moving videoScan and audioScan into PlayListFileViewsimon4-12/+14
2002-12-04- merged scanForVideo and scanForAudio into a common scanFiles method insimon6-28/+37
2002-12-03- a couple of public member variables made privatesimon1-6/+8
2002-12-03- removing ten lines of duplicated codesimon2-20/+10
2002-12-03- starting to factor out the playlist file views into separate classessimon6-4/+65
2002-12-02- I better be a good boy and delete what I allocate :)simon1-0/+2