Age | Commit message (Expand) | Author | Files | Lines |
2002-12-09 | - oops, buttonType is a bad name for a variable, given its redundancy | simon | 3 | -7/+7 |
2002-12-09 | - re-organizing a bit the button storage. more to come. | simon | 2 | -21/+28 |
2002-12-09 | - isToggle is now an enum ButtonType { NormalButton, ToggleButton }; | simon | 3 | -13/+10 |
2002-12-09 | - another hardcoded number removed :) | simon | 1 | -1/+1 |
2002-12-09 | - buttonPixUp/Down are now vectors, too | simon | 2 | -18/+10 |
2002-12-09 | - use a vector to store the masks | simon | 2 | -11/+12 |
2002-12-09 | - one global variable less | simon | 2 | -4/+4 |
2002-12-09 | switch (mouse) { | simon | 1 | -4/+4 |
2002-12-09 | - replaced currentFileListView method with a variable | simon | 2 | -17/+12 |
2002-12-09 | - use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE and | simon | 3 | -8/+4 |
2002-12-09 | - Key_Space triggers togglePaused() | simon | 1 | -9/+1 |
2002-12-08 | - synchronizing the button indices a bit more with the audiowidget | simon | 2 | -6/+6 |
2002-12-08 | - merged the two duplicated toggleButton methods into a shared one | simon | 6 | -17/+9 |
2002-12-08 | - oops, forgot to commit this one | simon | 1 | -0/+6 |
2002-12-08 | - some preparations for further code cleanups for paintButton calls | simon | 5 | -14/+17 |
2002-12-08 | - moved the duplicated code for checking whether the mouse is over a | simon | 4 | -12/+12 |
2002-12-08 | - merged xoff/yoff into a QPointe member variable, shared in the base class | simon | 5 | -17/+17 |
2002-12-08 | - made XineControl independent from VideoWidget | simon | 3 | -12/+11 |
2002-12-08 | - share the imgButtonMask member variable in the base class | simon | 5 | -14/+14 |
2002-12-08 | - no need to include audio and videowidget.h here | simon | 1 | -2/+0 |
2002-12-08 | - share the buttons data in a buttons member variable in the base class | simon | 5 | -50/+48 |
2002-12-08 | - #include cleanup | simon | 1 | -7/+0 |
2002-12-08 | - I'm re-using code from the others, so add their copyright :) | simon | 2 | -0/+6 |
2002-12-08 | - unused variables removed | simon | 3 | -39/+1 |
2002-12-08 | - made audioButtons a member variable here, too | simon | 2 | -4/+26 |
2002-12-08 | - made videoButtons a member variable instead of a global one | simon | 3 | -5/+29 |
2002-12-08 | - merged duplicated MediaButton definition into common MediaWidget::Button | simon | 3 | -9/+13 |
2002-12-08 | - minor cleanup | simon | 2 | -10/+15 |
2002-12-08 | - properly shut down xine in the destructor. fixes crashes when switching | simon | 1 | -0/+7 |
2002-12-08 | - when the file list view is visible only enable the play button if there | simon | 3 | -0/+40 |
2002-12-05 | - adapted to xine CVS HEAD | simon | 2 | -32/+37 |
2002-12-05 | - fixed a minor memory leak | simon | 1 | -9/+8 |
2002-12-05 | - turned if ( foo ) delete foo; into straight delete foo; as the if is | simon | 2 | -11/+8 |
2002-12-05 | damn.. wrong thing hehe | llornkcor | 1 | -1/+1 |
2002-12-05 | trying to keep up with tronical.. just removed unused parameters. | llornkcor | 2 | -2/+2 |
2002-12-04 | - scanForAudio and scanForVideo is scanFiles in the file list view, so | simon | 2 | -13/+2 |
2002-12-04 | - scannedFiles is no more public | simon | 2 | -20/+4 |
2002-12-04 | - the doclnkset is now fully encapsulated in PlayListFileView, no need | simon | 1 | -1/+0 |
2002-12-04 | - move more view population logic into PlayListFileView | simon | 4 | -28/+20 |
2002-12-04 | - merged popuplateAudioView and popuplateVideoView into one | simon | 4 | -74/+40 |
2002-12-04 | - moving videoScan and audioScan into PlayListFileView | simon | 4 | -12/+14 |
2002-12-04 | - merged scanForVideo and scanForAudio into a common scanFiles method in | simon | 6 | -28/+37 |
2002-12-03 | - a couple of public member variables made private | simon | 1 | -6/+8 |
2002-12-03 | - removing ten lines of duplicated code | simon | 2 | -20/+10 |
2002-12-03 | - starting to factor out the playlist file views into separate classes | simon | 6 | -4/+65 |
2002-12-02 | - I better be a good boy and delete what I allocate :) | simon | 1 | -0/+2 |
2002-12-02 | - yay, last singleton gone. global playList variable is no more :) | simon | 9 | -40/+36 |
2002-12-02 | - AudioWidget and VideoWidget are no more singletons via audioUI and | simon | 7 | -31/+56 |
2002-12-02 | - replaced QPixmap and QImage pointer usage with value usage | simon | 2 | -25/+23 |
2002-12-02 | - centralized closeEvent implementation | simon | 6 | -12/+7 |