summaryrefslogtreecommitdiffabout
path: root/src/Makefile.am
Side-by-side diff
Diffstat (limited to 'src/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..3810272
--- a/dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,18 @@
+sbin_PROGRAMS = dudki
+
+INCLUDES = ${DOTCONF_CFLAGS}
+LIBS += ${DOTCONF_LIBS}
+AM_CPPFLAGS = \
+ -DDEFAULT_CONF_FILE=\"${sysconfdir}/${PACKAGE}.conf\" \
+ -DDEFAULT_PID_FILE=\"/var/run/${PACKAGE}.pid\"
+
+dudki_SOURCES = dudki.cc \
+ process.cc process.h \
+ configuration.cc configuration.h \
+ util.cc util.h \
+ COPYING.cc
+
+COPYING.cc: ${top_srcdir}/COPYING
+ echo "const char * COPYING =" >$@ || (rm $@;exit 1)
+ sed 's/"/\\"/g' $< | sed 's/^/\"/' | sed 's/$$/\\n\"/' >>$@ || (rm $@;exit 1)
+ echo ";" >>$@ || (rm $@;exit 1)