summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e0e42c..3b409fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,9 @@ if $have_uuid ; then
AC_SUBST([UUID_UUID],[uuid])
fi
+PKG_CHECK_MODULES([SQLITE],[sqlite3],[have_sqlite=true],[have_sqlite=false])
+$have_sqlite && AC_DEFINE([HAVE_SQLITE],,[defined in presence of libsqlite3])
+
AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false])
test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.])