summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-02-13 14:02:29 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-13 14:02:29 (UTC)
commit4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80 (patch) (side-by-side diff)
tree47f2e6866ab812985ae9e6adbcea8bb785fa0403 /configure.ac
parentff4b919683537625f693eedf53006364d0f8444d (diff)
downloadkingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.zip
kingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.tar.gz
kingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.tar.bz2
1. Support for 'plain' CGI
2. Made fastcgi support optional 3. bumped version to 0.0.1 4. doxygen documentation target 'dox' is not built for 'all' now
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 109eddf..5ae7b27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([kingate], [0.0], [kingate-bugs@klever.net])
+AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net])
AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
@@ -12,17 +12,22 @@ AC_PROG_LIBTOOL
AC_HEADER_STDC
AC_CHECK_HEADERS([sys/types.h sys/stat.h])
+HAVE_FCGI=false
AC_LANG_PUSH(C++)
-AC_CHECK_HEADERS([fcgio.h],,[
- exit 1
-])
-AC_CHECK_LIB(fcgi,FCGX_Init,,[
- exit 1
-])
-AC_CHECK_LIB([fcgi++],[main],,[
- exit 1
+AC_CHECK_HEADERS([fcgio.h],[
+ AC_CHECK_LIB(fcgi,FCGX_Init,[
+ LIBS="-lfcgi ${LIBS}"
+ AC_CHECK_LIB([fcgi++],[main],[
+ LIBS="-lfcgi++ ${LIBS}"
+ HAVE_FCGI=true
+ ])
+ ])
])
AC_LANG_POP(C++)
+if ! ${HAVE_FCGI} ; then
+ AC_MSG_NOTICE([no FastCGI development kit found. It is highly recommnded that you get one. Meanwhile we will proceed without FastCGI support])
+fi
+AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
AC_C_CONST
@@ -54,7 +59,7 @@ fi
AC_CONFIG_FILES([
Makefile
- kingate.pc kingate-fcgi.pc
+ kingate.pc kingate-fcgi.pc kingate-plaincgi.pc
Doxyfile
include/Makefile
src/Makefile