summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-07-04 22:54:09 (UTC)
committer Michael Krelin <hacker@klever.net>2005-07-04 22:54:09 (UTC)
commitc5d7daf77e265b53951e1e2b09c51e2fba5e93dc (patch) (side-by-side diff)
tree2337ff96d85d8de6d25fbaed75eb9c0d71a1625d /configure.ac
parentc8bcbfb951eec5fe14dac0b14f4faaf4a9f9f229 (diff)
downloadkingate-c5d7daf77e265b53951e1e2b09c51e2fba5e93dc.zip
kingate-c5d7daf77e265b53951e1e2b09c51e2fba5e93dc.tar.gz
kingate-c5d7daf77e265b53951e1e2b09c51e2fba5e93dc.tar.bz2
1. awkward yet working support for POST file upload (requires mimetic)
2. support for NOT handling/parsing POSTed data (including application/x-www-form-urlencoded)
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b3141f1..b51d64d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net])
AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
-AC_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
AC_PROG_INSTALL
@@ -60,6 +60,20 @@ else
AM_CONDITIONAL([HAVE_DOT],[false])
fi
+HAVE_MIMETIC=false
+AC_LANG_PUSH(C++)
+ AC_CHECK_LIB([mimetic],[main],[
+ MIMETIC_LIBS=-lmimetic
+ HAVE_MIMETIC=true
+ ]
+ )
+AC_LANG_POP(C++)
+AC_SUBST([MIMETIC_LIBS])
+AC_SUBST([MIMETIC_CFLAGS])
+if ${HAVE_MIMETIC} ; then
+ AC_DEFINE([HAVE_MIMETIC],,[defined in presence of mimetic])
+fi
+
AC_CONFIG_FILES([
Makefile
kingate.pc kingate-fcgi.pc kingate-plaincgi.pc