summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Side-by-side diff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 9833732..3e9f0f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,24 +4,22 @@ EXTRA_DIST= NEWS NEWS.xml NEWS.xsl
DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig
if HAVE_PKGCONFIG
pkgconfigdir=@PKGCONFIG_DIR@
-pkgconfig_DATA=kingate.pc kingate-fcgi.pc
+pkgconfig_DATA=kingate.pc kingate-plaincgi.pc
+if HAVE_FCGI
+pkgconfig_DATA += kingate-fcgi.pc
+endif
endif
-LOCAL_TARGETS=
+all-local: NEWS
if HAVE_DOXYGEN
-LOCAL_TARGETS+=doxygen
+clean-local:
+ rm -rf doxydox
endif
-all-local: NEWS $(addprefix all-lota-,${LOCAL_TARGETS})
-clean-local: $(addprefix clean-lota-,${LOCAL_TARGETS})
-
NEWS: NEWS.xsl NEWS.xml
${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
-all-lota-doxygen: doxydox/built
-doxydox/built: $(wildcard ${top_srcdir}/include/kingate/*.h)
+if HAVE_DOXYGEN
+dox:
${DOXYGEN}
- touch $@
-
-clean-lota-doxygen:
- rm -rf doxydox
+endif