summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Unidiff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 9833732..3e9f0f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,24 +4,22 @@ EXTRA_DIST= NEWS NEWS.xml NEWS.xsl
4DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig 4DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig
5if HAVE_PKGCONFIG 5if HAVE_PKGCONFIG
6pkgconfigdir=@PKGCONFIG_DIR@ 6pkgconfigdir=@PKGCONFIG_DIR@
7pkgconfig_DATA=kingate.pc kingate-fcgi.pc 7pkgconfig_DATA=kingate.pc kingate-plaincgi.pc
8if HAVE_FCGI
9pkgconfig_DATA += kingate-fcgi.pc
10endif
8endif 11endif
9 12
10LOCAL_TARGETS= 13all-local: NEWS
11if HAVE_DOXYGEN 14if HAVE_DOXYGEN
12LOCAL_TARGETS+=doxygen 15clean-local:
16 rm -rf doxydox
13endif 17endif
14 18
15all-local: NEWS $(addprefix all-lota-,${LOCAL_TARGETS})
16clean-local: $(addprefix clean-lota-,${LOCAL_TARGETS})
17
18NEWS: NEWS.xsl NEWS.xml 19NEWS: NEWS.xsl NEWS.xml
19 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml 20 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
20 21
21all-lota-doxygen: doxydox/built 22if HAVE_DOXYGEN
22doxydox/built: $(wildcard ${top_srcdir}/include/kingate/*.h) 23dox:
23 ${DOXYGEN} 24 ${DOXYGEN}
24 touch $@ 25endif
25
26clean-lota-doxygen:
27 rm -rf doxydox