summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac62
1 files changed, 62 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..109eddf
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,62 @@
+AC_INIT([kingate], [0.0], [kingate-bugs@klever.net])
+AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AC_PROG_INSTALL
+AC_PROG_AWK
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+AC_HEADER_STDC
+AC_CHECK_HEADERS([sys/types.h sys/stat.h])
+
+AC_LANG_PUSH(C++)
+AC_CHECK_HEADERS([fcgio.h],,[
+ exit 1
+])
+AC_CHECK_LIB(fcgi,FCGX_Init,,[
+ exit 1
+])
+AC_CHECK_LIB([fcgi++],[main],,[
+ exit 1
+])
+AC_LANG_POP(C++)
+
+AC_C_CONST
+
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+
+AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
+
+AC_WITH_PKGCONFIG
+
+PKG_CHECK_MODULES([KONFORKA],[konforka],,[
+ AC_MSG_ERROR([no konforka library found. get one from http://kin.klever.net/konforka/])
+])
+
+WANT_DOXYGEN="yes"
+AC_ARG_ENABLE([doxygen],
+ AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
+ [
+ test "${enableval}" = "no" && WANT_DOXYGEN="no"
+ ]
+)
+if test "${WANT_DOXYGEN}" = "yes" ; then
+ AC_WITH_DOXYGEN
+ AC_WITH_DOT
+else
+ AM_CONDITIONAL([HAVE_DOXYGEN],[false])
+ AM_CONDITIONAL([HAVE_DOT],[false])
+fi
+
+AC_CONFIG_FILES([
+ Makefile
+ kingate.pc kingate-fcgi.pc
+ Doxyfile
+ include/Makefile
+ src/Makefile
+])
+AC_OUTPUT