summaryrefslogtreecommitdiffabout
path: root/lib/Makefile.am
authorMichael Krelin <hacker@klever.net>2005-01-29 19:41:34 (UTC)
committer Michael Krelin <hacker@klever.net>2005-01-29 19:41:34 (UTC)
commitee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e (patch) (side-by-side diff)
treebe8029ce4a68870d991651927a27df8ee9d89617 /lib/Makefile.am
parentd851b00e16839d6ec14da3a5c442be62ca868bba (diff)
downloadkonforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.zip
konforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.tar.gz
konforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.tar.bz2
initial commit.0.0
Diffstat (limited to 'lib/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--lib/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..a904569
--- a/dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,16 @@
+lib_LTLIBRARIES = libkonforka.la
+
+INCLUDES = -I${top_srcdir}/include
+AM_CXXFLAGS = ${PQXX_CFLAGS}
+LDADD = ${PQXX_LIBS}
+
+EXTRA_DIST = pqxx_pile.cc
+EXTRA_SOURCES=
+if HAVE_PQXX
+EXTRA_SOURCES += pqxx_pile.cc
+endif
+
+libkonforka_la_SOURCES = \
+ exception.cc \
+ pointer_map.cc \
+ ${EXTRA_SOURCES}