summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-11-19 19:02:42 (UTC)
committer Michael Krelin <hacker@klever.net>2007-11-19 19:02:42 (UTC)
commit09494e1183dba8879d438b57f6921f46518087b0 (patch) (side-by-side diff)
tree301fba19a5ec2dc4c8fc673b1c1efcfe4ddf069e /configure.ac
parentf2ccc66f71063d45f5bde741a69d9aae954d58da (diff)
downloadlibopkele-09494e1183dba8879d438b57f6921f46518087b0.zip
libopkele-09494e1183dba8879d438b57f6921f46518087b0.tar.gz
libopkele-09494e1183dba8879d438b57f6921f46518087b0.tar.bz2
pay attention to PCRE_{CFLAGS,LIBS} environment variables.
pkgconfig macros only check the variables in question if pkgconfig itself isn't available. Since libpcre prior to 5.0 lacks pkgconfig support I want PCRE_{CFLAGS,LIBS} variables to be _really_ influential. Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4f9b6c2..68872d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,9 +53,14 @@ LIBCURL_CHECK_CONFIG(,,,[
AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
])
-PKG_CHECK_MODULES([PCRE],[libpcre],,[
- AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
-])
+if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
+ AC_SUBST([PCRE_CFLAGS])
+ AC_SUBST([PCRE_LIBS])
+else
+ PKG_CHECK_MODULES([PCRE],[libpcre],,[
+ AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
+ ])
+fi
curl_ssl_verify_host="true"
AC_ARG_ENABLE([ssl-verify-host],