summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-12-27 00:23:57 (UTC)
committer Michael Krelin <hacker@klever.net>2008-01-04 18:18:06 (UTC)
commit2e8d7f2a65518ec6cb50166771dac8ca41c7304e (patch) (side-by-side diff)
tree28feefd75292f990f529b31c9c4f45b745bb9c1d /configure.ac
parent3802b70edcf11533e8a768c10086765558f79a64 (diff)
downloadlibopkele-2e8d7f2a65518ec6cb50166771dac8ca41c7304e.zip
libopkele-2e8d7f2a65518ec6cb50166771dac8ca41c7304e.tar.gz
libopkele-2e8d7f2a65518ec6cb50166771dac8ca41c7304e.tar.bz2
trying to make it report tr1/memory found nicely
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c4e9a74..9ad9710 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,7 +38,11 @@ AC_ARG_WITH([tr1-memory],
AC_MSG_CHECKING([for tr1/memory implementation to use])
test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
-test -z "$tr1_mem" && AC_MSG_RESULT([none found]) || AC_MSG_RESULT([$tr1_mem])
+if test -z "$tr1_mem" ; then
+ AC_MSG_RESULT([none found])
+else
+ AC_MSG_RESULT([$tr1_mem])
+fi
case "$tr1_mem" in
std)
$tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])