summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-06-18 21:38:12 (UTC)
committer Michael Krelin <hacker@klever.net>2007-06-18 21:38:12 (UTC)
commit3b404dd029a2aba05efc2edadcc7f67c59746cf7 (patch) (side-by-side diff)
treea972e6f7ab320927409cf773977b4ee58ce5cf68 /configure.ac
parente4873a10430d012943d2712b5b9c3363e8c74cb5 (diff)
downloadlibopkele-3b404dd029a2aba05efc2edadcc7f67c59746cf7.zip
libopkele-3b404dd029a2aba05efc2edadcc7f67c59746cf7.tar.gz
libopkele-3b404dd029a2aba05efc2edadcc7f67c59746cf7.tar.bz2
Adhere to Postel's Law.
That is, be liberal when parsing key/value parameters from remote. Along with configure switch to disable it.
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8397914..19e7832 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,13 @@ AC_ARG_ENABLE([ssl-verify-peer],
)
${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
+postels_law=true
+AC_ARG_ENABLE([postels-law],
+ AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
+ [ test "${enableval}" = "no" && postels_law=false ]
+)
+$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
+
AC_CONFIG_FILES([
Makefile
libopkele.pc