summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
authorMichael Krelin <hacker@klever.net>2008-02-03 16:18:47 (UTC)
committer Michael Krelin <hacker@klever.net>2008-02-03 16:18:47 (UTC)
commit7ee5acb351f43fa650de138f8d2a3bda73ab27a0 (patch) (side-by-side diff)
treef7e748688c620eebb767d83fbb70246e37fa1b62 /test/Makefile.am
parent434d42b37ecab09fc91ac8e6c752d3292c10a3b1 (diff)
downloadlibopkele-7ee5acb351f43fa650de138f8d2a3bda73ab27a0.zip
libopkele-7ee5acb351f43fa650de138f8d2a3bda73ab27a0.tar.gz
libopkele-7ee5acb351f43fa650de138f8d2a3bda73ab27a0.tar.bz2
added test OP
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'test/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--test/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 61e3787..8fedf48 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = test idiscover RP.cgi
+noinst_PROGRAMS = test idiscover RP.cgi OP.cgi
AM_CPPFLAGS=${CPPFLAGS_DEBUG}
DEFAULT_INCLUDES = -I${top_builddir}
@@ -8,8 +8,8 @@ test_SOURCES = test.cc
test_LDADD = ${top_builddir}/lib/libopkele.la
EXTRA_DIST= \
- sqlite.h \
- RP-db.sql
+ sqlite.h kingate_openid_message.h \
+ RP-db.sql OP-db.sql
idiscover_SOURCES = idiscover.cc
idiscover_LDADD = ${top_builddir}/lib/libopkele.la
@@ -31,8 +31,20 @@ RP-db.cc: RP-db.sql
echo ';' \
) >$@
+OP_cgi_SOURCES = OP.cc
+nodist_OP_cgi_SOURCES = OP-db.cc
+OP_cgi_LDADD = ${RP_cgi_LDADD}
+OP_cgi_CFLAGS = ${RP_cgi_CFLAGS}
+
+OP-db.cc: OP-db.sql
+ ( \
+ echo 'const char * __OP_db_bootstrap = ' && \
+ sed -e 's/^/"/' -e 's/$$/"/' $< && \
+ echo ';' \
+ ) >$@
+
clean-local:
- rm -f RP-db.cc
+ rm -f RP-db.cc OP-db.cc
endif #HAVE_UUID
endif #HAVE_KINGATE