summaryrefslogtreecommitdiffabout
path: root/lib/Makefile.am
authorMichael Krelin <hacker@klever.net>2006-08-11 16:01:56 (UTC)
committer Michael Krelin <hacker@klever.net>2006-08-11 16:01:56 (UTC)
commit0c21a7a0d5b84dc6726462f0fbe51b8c32433262 (patch) (side-by-side diff)
tree9df6334cb1a61efebe68f7bcef9aa119a823626a /lib/Makefile.am
parent9bcc235e575a95989a5903394c127accbeef2e0f (diff)
downloadmidillo-0c21a7a0d5b84dc6726462f0fbe51b8c32433262.zip
midillo-0c21a7a0d5b84dc6726462f0fbe51b8c32433262.tar.gz
midillo-0c21a7a0d5b84dc6726462f0fbe51b8c32433262.tar.bz2
initial commit into repository0.0
Diffstat (limited to 'lib/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--lib/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..de49c97
--- a/dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,15 @@
+lib_LTLIBRARIES = libmidillo.la
+
+INCLUDES = -I${top_srcdir}/include -I${top_srcdir}
+AM_CXXFLAGS = ${KONFORKA_CFLAGS}
+LDADD = ${KONFORKA_LIBS}
+
+libmidillo_la_SOURCES = \
+ util.cc \
+ SMF.cc \
+ chunk.cc \
+ MThd.cc MTrk.cc \
+ event.cc \
+ message.cc
+
+libmidillo_la_LDFLAGS = -version-info 0:0:0