summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Side-by-side diff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5a2a2c7
--- a/dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS=include lib tools man
+EXTRA_DIST= NEWS NEWS.xml NEWS.xsl
+
+DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig
+if HAVE_PKGCONFIG
+pkgconfigdir=@PKGCONFIG_DIR@
+pkgconfig_DATA=midillo.pc
+endif
+
+all-local: NEWS
+if HAVE_DOXYGEN
+clean-local:
+ rm -rf doxydox
+endif
+
+NEWS: NEWS.xsl NEWS.xml
+ ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
+
+if HAVE_DOXYGEN
+dox:
+ ${DOXYGEN}
+endif