summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Unidiff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5a2a2c7
--- a/dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
1SUBDIRS=include lib tools man
2EXTRA_DIST= NEWS NEWS.xml NEWS.xsl
3
4DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig
5if HAVE_PKGCONFIG
6pkgconfigdir=@PKGCONFIG_DIR@
7pkgconfig_DATA=midillo.pc
8endif
9
10all-local: NEWS
11if HAVE_DOXYGEN
12clean-local:
13 rm -rf doxydox
14endif
15
16NEWS: NEWS.xsl NEWS.xml
17 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
18
19if HAVE_DOXYGEN
20dox:
21 ${DOXYGEN}
22endif