summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2008-07-18 22:59:53 (UTC)
committer Michael Krelin <hacker@klever.net>2008-07-18 22:59:53 (UTC)
commitd1d3203e351e51cf905b3166f88c1a4d72140555 (patch) (side-by-side diff)
tree92a89f798591faacb3c8d2f3543971cb98b0b71e /configure.ac
parent04fb190243442e83349f129b523ab747e58100bf (diff)
downloadnapkin-d1d3203e351e51cf905b3166f88c1a4d72140555.zip
napkin-d1d3203e351e51cf905b3166f88c1a4d72140555.tar.gz
napkin-d1d3203e351e51cf905b3166f88c1a4d72140555.tar.bz2
make it build on Mac OS X with macports
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ca0b4e..fbf373b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,10 @@ AC_PROG_CC
AC_PROG_LIBTOOL
PKG_PROG_PKG_CONFIG
+onegetcwd=false
+AC_CHECK_FUNCS([get_current_dir_name getcwd],[onegetcwd=true;break])
+$onegetcwd || AC_MSG_ERROR([no function to get current directory found. weird.])
+
AC_HEADER_STDC
AC_PATH_PROG([XSLTPROC],[xsltproc],[true])