summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0da7658..b9e9b56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,8 +53,10 @@ AC_WITH_PCRE([
AC_MSG_ERROR([no pcre library found])
])
-AC_CHECK_LIB([dl],[dlopen],,[
- AC_MSG_ERROR([no dlopen library found])
+AC_CHECK_FUNC([dlopen],,[
+ AC_CHECK_LIB([dl],[dlopen],,[
+ AC_MSG_ERROR([no dlopen library found])
+ ])
])
AC_PATH_PROG([XSLTPROC],[xsltproc],[true])