summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index acd34b9..0da7658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([sitecing], [0.0], [sitecing-bugs@klever.net])
+AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net])
AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
@@ -20,9 +20,27 @@ AC_FUNC_REALLOC
AC_WITH_PKGCONFIG
-PKG_CHECK_MODULES([KINGATE],[kingate-fcgi],,[
+PKG_CHECK_MODULES([KINGATE],[kingate],,[
AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
])
+HAVE_FCGI=false
+HAVE_PLAINCGI=false
+PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi],[
+ HAVE_FCGI=true
+],[
+ AC_MSG_NOTICE([no fastcgi support in kingate library])
+])
+PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi],[
+ HAVE_PLAINCGI=true
+],[
+ AC_MSG_NOTICE([no plaincgi support in kingate library])
+])
+if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
+ AC_MSG_ERROR([not a single CGI interface supported in kingate])
+fi
+AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
+AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
+
PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
AC_MSG_ERROR([no dotconf library found])
])