summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index acd34b9..0da7658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1AC_INIT([sitecing], [0.0], [sitecing-bugs@klever.net]) 1AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h]) 2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
@@ -20,9 +20,27 @@ AC_FUNC_REALLOC
20 20
21AC_WITH_PKGCONFIG 21AC_WITH_PKGCONFIG
22 22
23PKG_CHECK_MODULES([KINGATE],[kingate-fcgi],,[ 23PKG_CHECK_MODULES([KINGATE],[kingate],,[
24 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/]) 24 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
25]) 25])
26HAVE_FCGI=false
27HAVE_PLAINCGI=false
28PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi],[
29 HAVE_FCGI=true
30],[
31 AC_MSG_NOTICE([no fastcgi support in kingate library])
32])
33PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi],[
34 HAVE_PLAINCGI=true
35],[
36 AC_MSG_NOTICE([no plaincgi support in kingate library])
37])
38if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
39 AC_MSG_ERROR([not a single CGI interface supported in kingate])
40fi
41AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
42AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
43
26PKG_CHECK_MODULES([DOTCONF],[dotconf],,[ 44PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
27 AC_MSG_ERROR([no dotconf library found]) 45 AC_MSG_ERROR([no dotconf library found])
28]) 46])