summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac69
1 files changed, 69 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..acd34b9
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,69 @@
+AC_INIT([sitecing], [0.0], [sitecing-bugs@klever.net])
+AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AC_PROG_INSTALL
+AC_PROG_AWK
+AC_PROG_CXX
+AC_PROG_CC
+AM_PROG_LEX
+AC_PROG_LIBTOOL
+
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h unistd.h])
+
+AC_C_CONST
+
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+
+AC_WITH_PKGCONFIG
+
+PKG_CHECK_MODULES([KINGATE],[kingate-fcgi],,[
+ AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
+])
+PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
+ AC_MSG_ERROR([no dotconf library found])
+])
+
+AC_WITH_PCRE([
+ AC_WITH_PCREPP(,[
+ AC_MSG_ERROR([no pcre++ library found])
+ ])
+],[
+ AC_MSG_ERROR([no pcre library found])
+])
+
+AC_CHECK_LIB([dl],[dlopen],,[
+ AC_MSG_ERROR([no dlopen library found])
+])
+
+AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
+
+WANT_DOXYGEN="yes"
+AC_ARG_ENABLE([doxygen],
+ AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
+ [
+ test "${enableval}" = "no" && WANT_DOXYGEN="no"
+ ]
+)
+if test "${WANT_DOXYGEN}" = "yes" ; then
+ AC_WITH_DOXYGEN
+ AC_WITH_DOT
+else
+ AM_CONDITIONAL([HAVE_DOXYGEN],[false])
+ AM_CONDITIONAL([HAVE_DOT],[false])
+fi
+
+AC_CONFIG_FILES([
+ Makefile
+ Doxyfile
+ sitecing.pc
+ include/Makefile
+ lib/Makefile
+ share/Makefile
+ src/Makefile
+ components/Makefile
+])
+AC_OUTPUT