summaryrefslogtreecommitdiff
path: root/sys-apps/dudki/dudki-0.2.2.ebuild
Side-by-side diff
Diffstat (limited to 'sys-apps/dudki/dudki-0.2.2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--sys-apps/dudki/dudki-0.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/dudki/dudki-0.2.2.ebuild b/sys-apps/dudki/dudki-0.2.2.ebuild
new file mode 100644
index 0000000..4d34712
--- a/dev/null
+++ b/sys-apps/dudki/dudki-0.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="The process maintenance daemon"
+HOMEPAGE="http://kin.klever.net/dudki/"
+SRC_URI="http://kin.klever.net/dist/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/dotconf-1.0.13
+ !sys-apps/dudki-svn"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "emake install failed"
+ insinto /etc
+ doins ${FILESDIR}/dudki.conf
+ dodoc AUTHORS COPYING NEWS
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dudki.init dudki
+ exeinto /etc/cron.daily ; newexe ${FILESDIR}/dudki.cron dudki
+}