summaryrefslogtreecommitdiff
path: root/sys-apps/dudki/dudki-0.2.2.ebuild
Unidiff
Diffstat (limited to 'sys-apps/dudki/dudki-0.2.2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--sys-apps/dudki/dudki-0.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/dudki/dudki-0.2.2.ebuild b/sys-apps/dudki/dudki-0.2.2.ebuild
new file mode 100644
index 0000000..4d34712
--- a/dev/null
+++ b/sys-apps/dudki/dudki-0.2.2.ebuild
@@ -0,0 +1,34 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils
6
7DESCRIPTION="The process maintenance daemon"
8HOMEPAGE="http://kin.klever.net/dudki/"
9SRC_URI="http://kin.klever.net/dist/${P}.tar.bz2"
10
11LICENSE="MIT"
12SLOT="0"
13KEYWORDS="~amd64 ~x86"
14IUSE=""
15
16RDEPEND=">=dev-libs/dotconf-1.0.13
17 !sys-apps/dudki-svn"
18DEPEND="${RDEPEND}
19 dev-util/pkgconfig"
20
21src_compile() {
22 econf || die "econf failed"
23 emake || die "emake failed"
24}
25
26src_install() {
27 make DESTDIR=${D} install || die "emake install failed"
28 insinto /etc
29 doins ${FILESDIR}/dudki.conf
30 dodoc AUTHORS COPYING NEWS
31
32 exeinto /etc/init.d ; newexe ${FILESDIR}/dudki.init dudki
33 exeinto /etc/cron.daily ; newexe ${FILESDIR}/dudki.cron dudki
34}