summaryrefslogtreecommitdiff
authorMichael Krelin <hacker@klever.net>2007-04-16 13:01:21 (UTC)
committer Michael Krelin <hacker@klever.net>2007-04-16 13:01:21 (UTC)
commit2ae8ba67d6f323d3678af8b2918cd757ca13a447 (patch) (side-by-side diff)
tree9b577259c46c2b4ac1eebc1040542e8aa0a3ab45
parent31eec028c0e04891aba43548a1d98d4ba15cd355 (diff)
downloadmisc-2ae8ba67d6f323d3678af8b2918cd757ca13a447.zip
misc-2ae8ba67d6f323d3678af8b2918cd757ca13a447.tar.gz
misc-2ae8ba67d6f323d3678af8b2918cd757ca13a447.tar.bz2
app-pda/pilot-link
Diffstat (more/less context) (ignore whitespace changes)
-rw-r--r--app-pda/pilot-link/Manifest12
-rw-r--r--app-pda/pilot-link/files/digest-pilot-link-0.12.23
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.2-build.patch89
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.2.ebuild70
4 files changed, 174 insertions, 0 deletions
diff --git a/app-pda/pilot-link/Manifest b/app-pda/pilot-link/Manifest
new file mode 100644
index 0000000..f96e0ce
--- a/dev/null
+++ b/app-pda/pilot-link/Manifest
@@ -0,0 +1,12 @@
+AUX pilot-link-0.12.2-build.patch 2809 RMD160 90af4c4f176d3df99cf5210ed4f7749dc458fd02 SHA1 36c4f331a91c966e1214a906a78614dfa2c78fd9 SHA256 5aed1036114e73cf982aab125d0e2ba6047a67e598d4b0af2808ffb15814f637
+MD5 cda93589fe3e5e64b172fac94137ba76 files/pilot-link-0.12.2-build.patch 2809
+RMD160 90af4c4f176d3df99cf5210ed4f7749dc458fd02 files/pilot-link-0.12.2-build.patch 2809
+SHA256 5aed1036114e73cf982aab125d0e2ba6047a67e598d4b0af2808ffb15814f637 files/pilot-link-0.12.2-build.patch 2809
+DIST pilot-link-0.12.2.tar.bz2 964014 RMD160 3ae19f16b28c33cccb19fa218cdad4353d479875 SHA1 29a2b355ad8b0680e655c7e1ffa1ebef1b2ad5d9 SHA256 809df99a97aae215f93c1a0863644c0d3411462a5bac2d16d4d8941ce9c6d150
+EBUILD pilot-link-0.12.2.ebuild 1690 RMD160 867a8d3d340594d7f918dcce2a064dcf0793d14a SHA1 40fb778e62606e88cb7681e69adcefdd8a9da5df SHA256 5c6ae2364a66e25f639affa5a35500cc47f23e13fc19ab3e1c439e6a4bf30f66
+MD5 9210106d711d2db30de66772d2cd055c pilot-link-0.12.2.ebuild 1690
+RMD160 867a8d3d340594d7f918dcce2a064dcf0793d14a pilot-link-0.12.2.ebuild 1690
+SHA256 5c6ae2364a66e25f639affa5a35500cc47f23e13fc19ab3e1c439e6a4bf30f66 pilot-link-0.12.2.ebuild 1690
+MD5 2d3563e047f94fe8adc2d327ff046b32 files/digest-pilot-link-0.12.2 256
+RMD160 1c7ca253534c3a18eba1c760b3bd71a143fafc23 files/digest-pilot-link-0.12.2 256
+SHA256 8e247afc68e1f741adcff994523248987e858ee23c07b3887ae03cb62d095ace files/digest-pilot-link-0.12.2 256
diff --git a/app-pda/pilot-link/files/digest-pilot-link-0.12.2 b/app-pda/pilot-link/files/digest-pilot-link-0.12.2
new file mode 100644
index 0000000..a009738
--- a/dev/null
+++ b/app-pda/pilot-link/files/digest-pilot-link-0.12.2
@@ -0,0 +1,3 @@
+MD5 c1f4db8f32a2ee916fedb9a2dac8aa26 pilot-link-0.12.2.tar.bz2 964014
+RMD160 3ae19f16b28c33cccb19fa218cdad4353d479875 pilot-link-0.12.2.tar.bz2 964014
+SHA256 809df99a97aae215f93c1a0863644c0d3411462a5bac2d16d4d8941ce9c6d150 pilot-link-0.12.2.tar.bz2 964014
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch b/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch
new file mode 100644
index 0000000..6d2c67d
--- a/dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch
@@ -0,0 +1,89 @@
+diff --git a/bindings/Java/Makefile.am b/bindings/Java/Makefile.am
+index a2ead24..1500dcd 100644
+--- a/bindings/Java/Makefile.am
++++ b/bindings/Java/Makefile.am
+@@ -67,6 +67,8 @@ java_classes= \
+ datebooktst.class \
+ adrtest.class
+
++$(java_classes): java_compile
++
+ java_compile: $(java_files)
+ $(JAVAC) -d . $(java_files)
+
+@@ -81,16 +83,16 @@ java_pisock: java_compile java_lib java_jar
+ install: all
+ ARCH=""; \
+ for a in i386 amd64 ppc; do \
+- if [ -e ${JAVABASE}/jre/lib/${a} ]; then \
+- ARCH="${a}"; \
++ if [ -e ${JAVABASE}/jre/lib/$${a} ]; then \
++ ARCH="$${a}"; \
+ break; \
+ fi; \
+ done; \
+- if [ -n "${ARCH}" ]; then \
++ if [ -n "$${ARCH}" ]; then \
+ echo "Unknown architecture. Copy lipijsock.so to ${JAVABASE}/jre/lib/ARCH/"; \
+ else \
+- mkdir -p "$(DESTDIR)${JAVABASE}/jre/lib/${ARCH}" && \
+- cp libjpisock.so "$(DESTDIR)${JAVABASE}/jre/lib/${ARCH}"; \
++ mkdir -p "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}" && \
++ cp libjpisock.so "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}"; \
+ echo "done."; \
+ fi
+
+diff --git a/configure.ac b/configure.ac
+index 68a05f2..4da0626 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -220,6 +220,7 @@ AC_MSG_RESULT($enable_conduits)
+ dnl ******************************
+ dnl PNG Support
+ dnl ******************************
++msg_png=no
+ if test "x$enable_conduits" != "xno"; then
+ have_png=no
+
+@@ -254,6 +255,7 @@ if test "x$enable_conduits" != "xno"; then
+ if test "$have_png" = yes; then
+ AC_DEFINE(HAVE_PNG, 1, [Define if we have PNG support])
+ have_png=yes
++ msg_png=yes
+ fi
+ fi
+ fi
+@@ -351,12 +353,13 @@ PKG_CHECK_MODULES(BLUEZ, bluez, have_bluez=yes, AC_MSG_RESULT(no))
+ AC_MSG_CHECKING([for BlueZ bluetooth support])
+ AC_ARG_WITH(bluez,
+ AC_HELP_STRING([--with-bluez],
+- [Enable usage of BlueZ]),,
++ [Enable usage of BlueZ]),[use_bluez="$withval"],
+ use_bluez=auto)
+ if test "x$use_bluez" != "xno"; then
+ if test "x$have_bluez" = xno && test "x$use_bluez" = xyes; then
+ AC_MSG_ERROR([BlueZ explicitly requested but no support found])
+ fi
++ use_bluez="$have_bluez"
+ if test "x$have_bluez" = xyes; then
+ AC_DEFINE(HAVE_BLUEZ, 1, [Define if we have BlueZ bluetooth support])
+ AC_MSG_RESULT([enabled])
+@@ -366,7 +369,7 @@ if test "x$use_bluez" != "xno"; then
+ fi
+ fi
+
+-AM_CONDITIONAL(WITH_BLUEZ, test x$have_bluez = "xyes")
++AM_CONDITIONAL(WITH_BLUEZ, test x$use_bluez != "xno")
+
+
+ dnl *********************************
+diff --git a/pilot-link.m4 b/pilot-link.m4
+index 129dfc3..a271c74 100644
+--- a/pilot-link.m4
++++ b/pilot-link.m4
+@@ -1,5 +1,3 @@
+-AC_DEFUN([IT_PROG_INTLTOOL], [AC_PREREQ([2.50])dnl
+-
+ AC_DEFUN([AC_PILOT_LINK_HOOK],
+ [
+ PILOT_LINK_VERS=0
diff --git a/app-pda/pilot-link/pilot-link-0.12.2.ebuild b/app-pda/pilot-link/pilot-link-0.12.2.ebuild
new file mode 100644
index 0000000..9c38cb4
--- a/dev/null
+++ b/app-pda/pilot-link/pilot-link-0.12.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+inherit perl-module eutils autotools toolchain-funcs
+
+DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
+HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="threads usb png bluetooth readline perl java tcl python"
+
+RDEPEND="virtual/libc
+ sys-libs/ncurses
+ usb? ( dev-libs/libusb )
+ png? ( media-libs/libpng )
+ bluetooth? ( net-wireless/bluez-libs )
+ readline? ( sys-libs/readline )
+ perl? ( dev-lang/perl )
+ java? ( virtual/jre )
+ tcl? ( dev-lang/tcl dev-lang/tk )
+ python? ( dev-lang/python )
+ "
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )
+ "
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoconf
+ eautomake
+}
+
+src_compile() {
+ econf \
+ --includedir=/usr/include/libpisock \
+ --enable-conduits \
+ $(use_enable threads) $(use_enable usb libusb) \
+ $(use_with png libpng $(libpng-config --prefix)) \
+ $(use_with bluetooth bluez) \
+ $(use_with readline) $(use_with perl) $(use_with java) \
+ $(use_with tcl tcl /usr/$(get_libdir)) \
+ $(use_with python) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_install
+ fi
+}