summaryrefslogtreecommitdiff
path: root/dev-libs/mimetic/mimetic-0.9.1.ebuild
authorMichael Krelin <hacker@klever.net>2007-02-21 22:27:52 (UTC)
committer Michael Krelin <hacker@klever.net>2007-02-21 22:27:52 (UTC)
commit84f570f19365e5f7d8381081b5606a0d6f5531d9 (patch) (side-by-side diff)
tree5e9930d01bf8c21929f8ecef5c6fc88efba238e5 /dev-libs/mimetic/mimetic-0.9.1.ebuild
parent40092ef2fa69ab4c44b7c993913efc1ada4c070c (diff)
downloadmisc-84f570f19365e5f7d8381081b5606a0d6f5531d9.zip
misc-84f570f19365e5f7d8381081b5606a0d6f5531d9.tar.gz
misc-84f570f19365e5f7d8381081b5606a0d6f5531d9.tar.bz2
mimetic
Diffstat (limited to 'dev-libs/mimetic/mimetic-0.9.1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/mimetic/mimetic-0.9.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/mimetic/mimetic-0.9.1.ebuild b/dev-libs/mimetic/mimetic-0.9.1.ebuild
new file mode 100644
index 0000000..739b018
--- a/dev/null
+++ b/dev-libs/mimetic/mimetic-0.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="MIME library written in C++ designed to be easy to use and integrate but yet fast and efficient."
+HOMEPAGE="http://codesink.org/mimetic_mime_library.html"
+SRC_URI="http://codesink.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="stlport doc examples"
+
+DEPEND="stlport? ( dev-libs/STLport )"
+
+src_compile() {
+ econf \
+ $(use stlport && echo --with-stlport) \
+ || die "econf failed"
+ emake || die "emake failed"
+ use doc && ( emake -C doc docs || die "emake docs failed" )
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ docinto examples
+ dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
+ fi
+}