summaryrefslogtreecommitdiff
path: root/dev-libs/mimetic/mimetic-0.9.3.ebuild
authorMichael Krelin <hacker@klever.net>2007-04-18 18:00:14 (UTC)
committer Michael Krelin <hacker@klever.net>2007-04-18 18:00:14 (UTC)
commit4243b8fe439f0f819b797d908345bd8ffc067ead (patch) (side-by-side diff)
tree8e0bbd0a23bf16e218e5af66f4c4e3569ad5ac24 /dev-libs/mimetic/mimetic-0.9.3.ebuild
parentc485564f09642aefcfa2ec23ac887589f7dc1843 (diff)
downloadmisc-4243b8fe439f0f819b797d908345bd8ffc067ead.zip
misc-4243b8fe439f0f819b797d908345bd8ffc067ead.tar.gz
misc-4243b8fe439f0f819b797d908345bd8ffc067ead.tar.bz2
dev-libs/mimetic: version bump to 0.9.3
Diffstat (limited to 'dev-libs/mimetic/mimetic-0.9.3.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/mimetic/mimetic-0.9.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/mimetic/mimetic-0.9.3.ebuild b/dev-libs/mimetic/mimetic-0.9.3.ebuild
new file mode 100644
index 0000000..739b018
--- a/dev/null
+++ b/dev-libs/mimetic/mimetic-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="MIME library written in C++ designed to be easy to use and integrate but yet fast and efficient."
+HOMEPAGE="http://codesink.org/mimetic_mime_library.html"
+SRC_URI="http://codesink.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="stlport doc examples"
+
+DEPEND="stlport? ( dev-libs/STLport )"
+
+src_compile() {
+ econf \
+ $(use stlport && echo --with-stlport) \
+ || die "econf failed"
+ emake || die "emake failed"
+ use doc && ( emake -C doc docs || die "emake docs failed" )
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ docinto examples
+ dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
+ fi
+}