summaryrefslogtreecommitdiff
path: root/x11-plugins/asmem/asmem-1.10-r1.ebuild
authorMichael Krelin <hacker@klever.net>2007-04-09 17:30:16 (UTC)
committer Michael Krelin <hacker@klever.net>2007-04-09 17:30:16 (UTC)
commit3194f10a8ecf29cc25ef1243fd005fa05f16bb74 (patch) (side-by-side diff)
tree901e674748dca4512a480f03d2ae14f7321c11d2 /x11-plugins/asmem/asmem-1.10-r1.ebuild
parenta993965037116107d4cc5b0f9d712464592d9603 (diff)
downloadmisc-3194f10a8ecf29cc25ef1243fd005fa05f16bb74.zip
misc-3194f10a8ecf29cc25ef1243fd005fa05f16bb74.tar.gz
misc-3194f10a8ecf29cc25ef1243fd005fa05f16bb74.tar.bz2
x11-plugins: imported from portage
Diffstat (limited to 'x11-plugins/asmem/asmem-1.10-r1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--x11-plugins/asmem/asmem-1.10-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/asmem/asmem-1.10-r1.ebuild b/x11-plugins/asmem/asmem-1.10-r1.ebuild
new file mode 100644
index 0000000..caba379
--- a/dev/null
+++ b/x11-plugins/asmem/asmem-1.10-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asmem/asmem-1.10-r1.ebuild,v 1.6 2006/11/27 12:52:26 gustavoz Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="jpeg"
+DESCRIPTION="Memory statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/asmem/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README
+}