summaryrefslogtreecommitdiff
path: root/x11-plugins/asmem/asmem-1.12.ebuild
authorMichael Krelin <hacker@klever.net>2007-04-12 21:48:28 (UTC)
committer Michael Krelin <hacker@klever.net>2007-04-12 21:48:28 (UTC)
commitb83f4f686b1c080d2e286e4c967c5777c5bda0a4 (patch) (side-by-side diff)
tree90e22c513c13ee2337e85246388b7b54f5066385 /x11-plugins/asmem/asmem-1.12.ebuild
parent3194f10a8ecf29cc25ef1243fd005fa05f16bb74 (diff)
downloadmisc-b83f4f686b1c080d2e286e4c967c5777c5bda0a4.zip
misc-b83f4f686b1c080d2e286e4c967c5777c5bda0a4.tar.gz
misc-b83f4f686b1c080d2e286e4c967c5777c5bda0a4.tar.bz2
x11-plugins/asmem: version bump to 1.12
Diffstat (limited to 'x11-plugins/asmem/asmem-1.12.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--x11-plugins/asmem/asmem-1.12.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/asmem/asmem-1.12.ebuild b/x11-plugins/asmem/asmem-1.12.ebuild
new file mode 100644
index 0000000..7a69d58
--- a/dev/null
+++ b/x11-plugins/asmem/asmem-1.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+IUSE="jpeg"
+DESCRIPTION="Memory statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/asmem/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README
+}