summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
Side-by-side diff
Diffstat (limited to 'dev-db/schemaspy-svn/schemaspy-svn-345.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy-svn/schemaspy-svn-345.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild b/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
new file mode 100644
index 0000000..b61d184
--- a/dev/null
+++ b/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion eutils java-pkg-2 java-ant-2
+
+OPN="${PN%-svn}"
+
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/${OPN}/trunk"
+ESVN_PROJECT="schemaspy"
+ESVN_OPTIONS="-r${PV}"
+
+DESCRIPTION="Graphical database schema metadata browser"
+HOMEPAGE="http://schemaspy.sourceforge.net/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres firebird oracle mysql"
+
+JDEPEND="
+ postgres? ( dev-java/jdbc-postgresql )
+ firebird? ( dev-java/jdbc3-firebird )
+ oracle? ( dev-java/jdbc3-oracle )
+ mysql? ( dev-java/jdbc-mysql )
+"
+DEPEND="$JDEPEND
+ >=virtual/jdk-1.5
+ dev-java/ant-core
+ app-arch/unzip
+"
+RDEPEND="$JDEPEND
+ >=virtual/jre-1.5
+ !dev-db/schemaspy
+"
+
+src_unpack() {
+ subversion_src_unpack
+ use postgres && java-pkg_jar-from jdbc-postgresql
+ use firebird && java-pkg_jar-from jdbc3-firebird
+ # XXX: I don't know if it's the right name for oracle package
+ use oracle && java-pkg_jar-from jdbc3-oracle
+ use mysql && java-pkg_jar-from jdbc-mysql
+}
+
+src_compile() {
+ eant || die "Failed compile"
+}
+
+src_install() {
+ java-pkg_dojar dist/schemaSpy.jar
+ java-pkg_dolauncher ${OPN}
+ insinto /etc/java-config-2/launcher.d/
+ newins ${FILESDIR}/${OPN}.launcherd ${PN}
+ dodoc dist/index.html dist/releaseNotes.html
+}