summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
Unidiff
Diffstat (limited to 'dev-db/schemaspy-svn/schemaspy-svn-345.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy-svn/schemaspy-svn-345.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild b/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
new file mode 100644
index 0000000..b61d184
--- a/dev/null
+++ b/dev-db/schemaspy-svn/schemaspy-svn-345.ebuild
@@ -0,0 +1,55 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit subversion eutils java-pkg-2 java-ant-2
6
7OPN="${PN%-svn}"
8
9ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/${OPN}/trunk"
10ESVN_PROJECT="schemaspy"
11ESVN_OPTIONS="-r${PV}"
12
13DESCRIPTION="Graphical database schema metadata browser"
14HOMEPAGE="http://schemaspy.sourceforge.net/"
15LICENSE="LGPL-2.1"
16SLOT="0"
17KEYWORDS="~amd64 ~x86"
18IUSE="postgres firebird oracle mysql"
19
20JDEPEND="
21 postgres? ( dev-java/jdbc-postgresql )
22 firebird? ( dev-java/jdbc3-firebird )
23 oracle? ( dev-java/jdbc3-oracle )
24 mysql? ( dev-java/jdbc-mysql )
25"
26DEPEND="$JDEPEND
27 >=virtual/jdk-1.5
28 dev-java/ant-core
29 app-arch/unzip
30"
31RDEPEND="$JDEPEND
32 >=virtual/jre-1.5
33 !dev-db/schemaspy
34"
35
36src_unpack() {
37 subversion_src_unpack
38 use postgres && java-pkg_jar-from jdbc-postgresql
39 use firebird && java-pkg_jar-from jdbc3-firebird
40 # XXX: I don't know if it's the right name for oracle package
41 use oracle && java-pkg_jar-from jdbc3-oracle
42 use mysql && java-pkg_jar-from jdbc-mysql
43}
44
45src_compile() {
46 eant || die "Failed compile"
47}
48
49src_install() {
50 java-pkg_dojar dist/schemaSpy.jar
51 java-pkg_dolauncher ${OPN}
52 insinto /etc/java-config-2/launcher.d/
53 newins ${FILESDIR}/${OPN}.launcherd ${PN}
54 dodoc dist/index.html dist/releaseNotes.html
55}