summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy/schemaspy-3.1.1.ebuild
Side-by-side diff
Diffstat (limited to 'dev-db/schemaspy/schemaspy-3.1.1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy/schemaspy-3.1.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/schemaspy/schemaspy-3.1.1.ebuild b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
new file mode 100644
index 0000000..6e18518
--- a/dev/null
+++ b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Graphical database schema metadata browser"
+HOMEPAGE="http://schemaspy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/schemaSpy_${PV}.source.jar"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="postgres firebird oracle mysql"
+
+DEPEND="
+ >=virtual/jdk-1.4
+ dev-java/ant-core
+ app-arch/unzip
+"
+RDEPEND="
+ >=virtual/jre-1.4
+ postgres? ( dev-java/jdbc3-postgresql )
+ firebird? ( dev-java/jdbc3-firebird )
+ oracle? ( dev-java/jdbc3-oracle )
+ mysql? ( dev-java/jdbc-mysql )
+ !dev-db/schemaspy-svn
+"
+
+src_unpack() {
+ mkdir "${S}"
+ cd "${S}"
+ unpack "${A}"
+ cp ${FILESDIR}/build.xml ./
+ rm -rf META-INF/
+ mkdir src
+ mv net *.css images src
+ use postgres && java-pkg_jar-from jdbc3-postgresql-1
+ use firebird && java-pkg_jar-from jdbc3-firebird
+ # XXX: I don't know if it's the right name for oracle package
+ use oracle && java-pkg_jar-from jdbc3-oracle
+ use mysql && java-pkg_jar-from jdbc-mysql
+}
+
+src_compile() {
+ eant || die "Failed complie"
+}
+
+src_install() {
+ java-pkg_dojar dist/schemaSpy.jar
+ java-pkg_dolauncher ${PN}
+ insinto /etc/java-config-2/launcher.d/
+ newins ${FILESDIR}/schemaspy.launcherd ${PN}
+}