summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy/schemaspy-3.1.1.ebuild
Unidiff
Diffstat (limited to 'dev-db/schemaspy/schemaspy-3.1.1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy/schemaspy-3.1.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/schemaspy/schemaspy-3.1.1.ebuild b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
new file mode 100644
index 0000000..6e18518
--- a/dev/null
+++ b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
@@ -0,0 +1,53 @@
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils java-pkg-2 java-ant-2
6
7DESCRIPTION="Graphical database schema metadata browser"
8HOMEPAGE="http://schemaspy.sourceforge.net/"
9SRC_URI="mirror://sourceforge/${PN}/schemaSpy_${PV}.source.jar"
10LICENSE="LGPL"
11SLOT="0"
12KEYWORDS="~x86 ~amd64"
13IUSE="postgres firebird oracle mysql"
14
15DEPEND="
16 >=virtual/jdk-1.4
17 dev-java/ant-core
18 app-arch/unzip
19"
20RDEPEND="
21 >=virtual/jre-1.4
22 postgres? ( dev-java/jdbc3-postgresql )
23 firebird? ( dev-java/jdbc3-firebird )
24 oracle? ( dev-java/jdbc3-oracle )
25 mysql? ( dev-java/jdbc-mysql )
26 !dev-db/schemaspy-svn
27"
28
29src_unpack() {
30 mkdir "${S}"
31 cd "${S}"
32 unpack "${A}"
33 cp ${FILESDIR}/build.xml ./
34 rm -rf META-INF/
35 mkdir src
36 mv net *.css images src
37 use postgres && java-pkg_jar-from jdbc3-postgresql-1
38 use firebird && java-pkg_jar-from jdbc3-firebird
39 # XXX: I don't know if it's the right name for oracle package
40 use oracle && java-pkg_jar-from jdbc3-oracle
41 use mysql && java-pkg_jar-from jdbc-mysql
42}
43
44src_compile() {
45 eant || die "Failed complie"
46}
47
48src_install() {
49 java-pkg_dojar dist/schemaSpy.jar
50 java-pkg_dolauncher ${PN}
51 insinto /etc/java-config-2/launcher.d/
52 newins ${FILESDIR}/schemaspy.launcherd ${PN}
53}