summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy/schemaspy-3.1.1.ebuild
Side-by-side diff
Diffstat (limited to 'dev-db/schemaspy/schemaspy-3.1.1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-db/schemaspy/schemaspy-3.1.1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-db/schemaspy/schemaspy-3.1.1.ebuild b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
index 9945e00..131c84f 100644
--- a/dev-db/schemaspy/schemaspy-3.1.1.ebuild
+++ b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
@@ -12,17 +12,19 @@ SLOT="0"
KEYWORDS="x86 amd64"
IUSE="postgres firebird oracle mysql"
-DEPEND="
+JDEPEND="
+ postgres? ( dev-java/jdbc-postgresql )
+ firebird? ( dev-java/jdbc3-firebird )
+ oracle? ( dev-java/jdbc3-oracle )
+ mysql? ( dev-java/jdbc-mysql )
+"
+DEPEND="$JDEPEND
>=virtual/jdk-1.4
dev-java/ant-core
app-arch/unzip
"
-RDEPEND="
+RDEPEND="$JDEPEND
>=virtual/jre-1.4
- postgres? ( dev-java/jdbc3-postgresql )
- firebird? ( dev-java/jdbc3-firebird )
- oracle? ( dev-java/jdbc3-oracle )
- mysql? ( dev-java/jdbc-mysql )
!dev-db/schemaspy-svn
"
@@ -34,7 +36,7 @@ src_unpack() {
rm -rf META-INF/
mkdir src
mv net *.css images src
- use postgres && java-pkg_jar-from jdbc3-postgresql-1
+ use postgres && java-pkg_jar-from jdbc-postgresql
use firebird && java-pkg_jar-from jdbc3-firebird
# XXX: I don't know if it's the right name for oracle package
use oracle && java-pkg_jar-from jdbc3-oracle