summaryrefslogtreecommitdiff
path: root/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
Unidiff
Diffstat (limited to 'dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
new file mode 100644
index 0000000..6823ca6
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
@@ -0,0 +1,30 @@
1diff -Naur ibpp.orig/Makefile ibpp/Makefile
2 --- ibpp.orig/Makefile2004-09-27 14:08:44.000000000 -0400
3 +++ ibpp/Makefile2005-09-16 02:44:37.000000000 -0400
4@@ -164,20 +164,19 @@
5 # building on linux (any flavour, I suppose)
6 ifeq ($(PLATFORM),linux)
7 CXXOUTPUT =-o
8 -CXXFLAGS =-DIBPP_LINUX
9 -CXXFLAGS+=-DIBPP_GCC
10 -CXXFLAGS+=-I./ -I./fbheaders
11 #
12 # change -lfbclient by -lgds if building with Firebird 1.x or InterBase
13 # -lfbclient (or -lgds) is for Firebird 1.5 SS and higher
14 # -lfbembed is for Firebird 1.5 CS and higher
15 #
16 LIBS+=-lfbclient -lcrypt -lm -ldl -lpthread # dependancies for shared library
17 -ifeq ($(TARGETDIR),release)
18 - CXXFLAGS+= -O3
19 -else
20 - CXXFLAGS+= -g -DDEBUG -Wall
21 +ifeq ($(TARGETDIR),debug)
22 + CXXFLAGS=-g -DDEBUG -Wall
23 endif
24 +CXXFLAGS+=-fPIC
25 +CXXFLAGS+=-DIBPP_LINUX
26 +CXXFLAGS+=-DIBPP_GCC
27 +CXXFLAGS+=-I./ -I./fbheaders
28 #
29 TARGETS =$(TARGETDIR)/$(PLATFORM)/libibpp.a \
30 $(TARGETDIR)/$(PLATFORM)/libibpp.so \