summaryrefslogtreecommitdiff
path: root/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
Side-by-side diff
Diffstat (limited to 'dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
new file mode 100644
index 0000000..6823ca6
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
@@ -0,0 +1,30 @@
+diff -Naur ibpp.orig/Makefile ibpp/Makefile
+--- ibpp.orig/Makefile 2004-09-27 14:08:44.000000000 -0400
++++ ibpp/Makefile 2005-09-16 02:44:37.000000000 -0400
+@@ -164,20 +164,19 @@
+ # building on linux (any flavour, I suppose)
+ ifeq ($(PLATFORM),linux)
+ CXXOUTPUT = -o
+- CXXFLAGS =-DIBPP_LINUX
+- CXXFLAGS+=-DIBPP_GCC
+- CXXFLAGS+=-I./ -I./fbheaders
+ #
+ # change -lfbclient by -lgds if building with Firebird 1.x or InterBase
+ # -lfbclient (or -lgds) is for Firebird 1.5 SS and higher
+ # -lfbembed is for Firebird 1.5 CS and higher
+ #
+ LIBS+=-lfbclient -lcrypt -lm -ldl -lpthread # dependancies for shared library
+- ifeq ($(TARGETDIR),release)
+- CXXFLAGS+= -O3
+- else
+- CXXFLAGS+= -g -DDEBUG -Wall
++ ifeq ($(TARGETDIR),debug)
++ CXXFLAGS=-g -DDEBUG -Wall
+ endif
++ CXXFLAGS+=-fPIC
++ CXXFLAGS+=-DIBPP_LINUX
++ CXXFLAGS+=-DIBPP_GCC
++ CXXFLAGS+=-I./ -I./fbheaders
+ #
+ TARGETS = $(TARGETDIR)/$(PLATFORM)/libibpp.a \
+ $(TARGETDIR)/$(PLATFORM)/libibpp.so \