summaryrefslogtreecommitdiff
path: root/dev-libs/ibpp/files
Side-by-side diff
Diffstat (limited to 'dev-libs/ibpp/files') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/ibpp/files/digest-ibpp-2.3.5.03
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch30
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch21
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/ibpp/files/digest-ibpp-2.3.5.0 b/dev-libs/ibpp/files/digest-ibpp-2.3.5.0
new file mode 100644
index 0000000..62f93d1
--- a/dev/null
+++ b/dev-libs/ibpp/files/digest-ibpp-2.3.5.0
@@ -0,0 +1,3 @@
+MD5 f96991555dec3c98216e0d78f31b8586 ibpp-2-3-5-0-src.zip 126081
+RMD160 02226aabc07177b4b24595667301b5d39cc483b2 ibpp-2-3-5-0-src.zip 126081
+SHA256 422a72596f933ab81a9097dcf3d6ad275bf148ea260a15e68456fa1ad01e0eed ibpp-2-3-5-0-src.zip 126081
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
new file mode 100644
index 0000000..6823ca6
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
@@ -0,0 +1,30 @@
+diff -Naur ibpp.orig/Makefile ibpp/Makefile
+--- ibpp.orig/Makefile 2004-09-27 14:08:44.000000000 -0400
++++ ibpp/Makefile 2005-09-16 02:44:37.000000000 -0400
+@@ -164,20 +164,19 @@
+ # building on linux (any flavour, I suppose)
+ ifeq ($(PLATFORM),linux)
+ CXXOUTPUT = -o
+- CXXFLAGS =-DIBPP_LINUX
+- CXXFLAGS+=-DIBPP_GCC
+- CXXFLAGS+=-I./ -I./fbheaders
+ #
+ # change -lfbclient by -lgds if building with Firebird 1.x or InterBase
+ # -lfbclient (or -lgds) is for Firebird 1.5 SS and higher
+ # -lfbembed is for Firebird 1.5 CS and higher
+ #
+ LIBS+=-lfbclient -lcrypt -lm -ldl -lpthread # dependancies for shared library
+- ifeq ($(TARGETDIR),release)
+- CXXFLAGS+= -O3
+- else
+- CXXFLAGS+= -g -DDEBUG -Wall
++ ifeq ($(TARGETDIR),debug)
++ CXXFLAGS=-g -DDEBUG -Wall
+ endif
++ CXXFLAGS+=-fPIC
++ CXXFLAGS+=-DIBPP_LINUX
++ CXXFLAGS+=-DIBPP_GCC
++ CXXFLAGS+=-I./ -I./fbheaders
+ #
+ TARGETS = $(TARGETDIR)/$(PLATFORM)/libibpp.a \
+ $(TARGETDIR)/$(PLATFORM)/libibpp.so \
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch
new file mode 100644
index 0000000..283a46b
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch
@@ -0,0 +1,21 @@
+diff -Naur ibpp.orig/array.cpp ibpp/array.cpp
+--- ibpp.orig/array.cpp 2004-09-23 17:34:08.000000000 +0200
++++ ibpp/array.cpp 2004-10-25 22:51:01.000000000 +0200
+@@ -289,7 +289,7 @@
+ throw ExceptionImpl("Array::ReadTo", "Wrong count of array elements");
+
+ IBS status;
+- long lenbuf = mBufferSize;
++ ISC_LONG lenbuf = mBufferSize;
+ (*gds.Call()->m_array_get_slice)(status.Self(), mDatabase->GetHandlePtr(),
+ mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
+ if (status.Errors())
+@@ -1088,7 +1088,7 @@
+ }
+
+ IBS status;
+- long lenbuf = mBufferSize;
++ ISC_LONG lenbuf = mBufferSize;
+ (*gds.Call()->m_array_put_slice)(status.Self(), mDatabase->GetHandlePtr(),
+ mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
+ if (status.Errors())